List question default value issue

More
4 years 4 months ago #88593 by Civette
Hi,

I'm running Version 2.00+ Build 121117 and I'm in trouble with a List question (dropdown box).

I have 11 values from 0 to 10 ( as displayed text ) with related code equal ( 0 to 10 ). I need this for an underlyinq equation question with a calculation.

When I set default answer as 0 and save it. It comes back to 1.

Has this behaviour ever been noticed before ?

Thank you,

Please Log in to join the conversation.

More
4 years 4 months ago - 4 years 4 months ago #89251 by Civette
Up...

Has anyone an idea ?
Last Edit: 4 years 4 months ago by Civette.

Please Log in to join the conversation.

More
4 years 4 months ago #89319 by tpartner
Civette, can you attach a sample survey for us to test?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 3 months ago #89335 by Civette
Sure, here it is

File Attachment:

File Name: limesurvey...9651.lss
File Size:73 KB


Concerned questions are Plat_A , Plat_B and Plat_C in third group. It is in french but it should be obvious to see the issue.
Attachments:

Please Log in to join the conversation.

More
4 years 3 months ago #89409 by Mazi
I can NOT reproduce this problem with my own test survey at the latest Limesurvey 2 version. If I enter "0" as answer code, this isn't changed to "1".

Please update and check if the problem was solved.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 3 months ago - 4 years 3 months ago #89411 by Civette
Hi Mazi

My version is up to date

additional info, I think you misunderstood the issue.

Ther are eleven possible values with the related answer code. In this case code and displayed values are the same.

Code -> Value
0 -> 0
1 -> 1
...
10-> 10

I need the code to be a number as I need it for a calculation.

Default proposed value should be 0 ( with "0" displayed )

If I change the default answer to 0, it is always 1 that displays.

Is it more clear ?
Last Edit: 4 years 3 months ago by Civette.

Please Log in to join the conversation.

More
4 years 3 months ago #89413 by tpartner
Civette, how are you setting the default value?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 3 months ago #89447 by Civette
Hi,

Please see attached file.

I click the "default answer" button, select 0, save the setting and when I come back value is still 1.
Attachments:

Please Log in to join the conversation.

More
4 years 3 months ago #89459 by tpartner
Okay, it seems to be a bug.

Please file a bug report and...
1. Give as much information as possible.
2. Provide step-by-step instructions how to reproduce the problem.
3. Provide screenshots and a sample survey.
4. Post the link to the bug here so we can follow the progress.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 3 months ago #89466 by Civette
OK, it has been reported as bug 07003

Please Log in to join the conversation.

More
4 years 3 months ago #89487 by Mazi
I assigend the problem to one of our developers. It should be fixed soon.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 3 months ago #89510 by Mazi

Mazi wrote: I assigend the problem to one of our developers. It should be fixed soon.

Bug fixed: bugs.limesurvey.org/view.php?id=7003

The fix will be included at the next weekly bugfix release which will probably be released within the next 48h-72h.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 3 months ago #89566 by Civette
I just updated and issue is fixed.

Thank you,

Please Log in to join the conversation.