Welcome, Guest
Username: Password:

TOPIC: html entities showing on error message

html entities showing on error message 3 years 8 months ago #84862

  • chinaski
  • chinaski's Avatar
  • Offline
  • Junior Lime
  • Posts: 24
  • Thank you received: 1
  • Karma: 0
I have a mandatory multiple choice field with an optional text box for 'other'.

When the form is submitted without choosing any of the choices the error message appears. In this case however the quote around the field name is displaying in it's html entity form:

This question is mandatory. Please check at least one item.
If you choose 'Other:', then please provide a description.

I need to either remove the quotes around Other in the message itself or maybe there is a setting someplace to remove the html entities encoding of the quote string.

Assistance is appreciated.
The administrator has disabled public write access.

html entities showing on error message 3 years 7 months ago #85037

  • tpartner
  • tpartner's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5760
  • Thank you received: 1250
  • Karma: 512
Can you please update to the latest version and retest?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

html entities showing on error message 3 years 7 months ago #85053

  • chinaski
  • chinaski's Avatar
  • Offline
  • Junior Lime
  • Posts: 24
  • Thank you received: 1
  • Karma: 0
I'm at the latest release according to the update checker, Version 1.92+ Build 120822.
The administrator has disabled public write access.

html entities showing on error message 3 years 7 months ago #85174

  • chinaski
  • chinaski's Avatar
  • Offline
  • Junior Lime
  • Posts: 24
  • Thank you received: 1
  • Karma: 0
Still seeing this behaviour. Any ideas?
The administrator has disabled public write access.

html entities showing on error message 3 years 7 months ago #86171

Hi all,

It seems I have the same problem.

With empty mandatory questions i get, in red, below the question, warnings with untranslated quotes (').
Indicating i need to write something when I choose 'other', which comes out as 'other'
(I use dutch so it actually is: 'Andere:' )

I use version 1.92+ Build 120919

What can i do to narrow down the problem?

Grtz
The administrator has disabled public write access.

html entities showing on error message 3 years 6 months ago #86988

  • dirkbece
  • dirkbece's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
I have the same problem, Is there a solution allready to fix this. I use version 1.92+ Build 120919
The administrator has disabled public write access.

html entities showing on error message 3 years 6 months ago #87001

  • tpartner
  • tpartner's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5760
  • Thank you received: 1250
  • Karma: 512
Can you please attach a sample survey?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

html entities showing on error message 3 years 6 months ago #87008

  • dirkbece
  • dirkbece's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
www.bcinfo.nl/index.php?sid=79446&newtest=Y&lang=nl

use code aaaa to get access

Regards,

Dirk
The administrator has disabled public write access.

html entities showing on error message 3 years 6 months ago #87011

  • tpartner
  • tpartner's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5760
  • Thank you received: 1250
  • Karma: 512
I don't see these warnings. Can you be more specific or give us a shorter survey?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

html entities showing on error message 3 years 6 months ago #87015

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 8716
  • Thank you received: 1214
  • Karma: 360
Yep,

Warnig message aren't shown in this survey.

I supposed you have someting like that:
If you choose &quote;Other :&quote; you must provide a description.

the patch for 2.0 github.com/LimeSurvey/LimeSurvey/commit/...af44bdd62fcc96bbdcbb.

For 1.92, you have to replace string in ./classes/expression/LimeExpressionManager.php and update the mo files.

Denis
Last Edit: 3 years 6 months ago by DenisChenu.
The administrator has disabled public write access.

html entities showing on error message 3 years 6 months ago #87020

  • dirkbece
  • dirkbece's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
./classes/expression/LimeExpressionManager.php
That code is 7000 lines.
Can you be a little more precise where i have to look and what i have to change?

Is there no patch for this version?

Regards,

Dirk
The administrator has disabled public write access.

html entities showing on error message 3 years 5 months ago #88055

  • suthex
  • suthex's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
Hi Dirk,

Did you ever get a reasonable answer as to where/how to change limesurvey/classes/expressions/LimeExpressionManager.php?

I have been trying to debug where my

If you choose 'Other:', then please provide a description

is coming from ... but damned if I can wrestle this one to the ground.

Much appreciated.
Doug
The administrator has disabled public write access.

html entities showing on error message 3 years 5 months ago #88058

  • c_schmitz
  • c_schmitz's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 974
  • Thank you received: 133
  • Karma: 97
The patch to fix this is this one:

github.com/LimeSurvey/LimeSurvey/commit/...e100508daa0e56a806b9

Just do the changes for the gT function in 1.92+.
Best regards

Carsten Schmitz
LimeSurvey project leader
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.222 seconds