Check out the LimeSurvey source code on GitHub!

slider layout messed up in IE - repost

More
4 years 6 months ago - 4 years 6 months ago #84790 by Xtale
hello,

sry for the duplicated post, I messed up the other thread :S

I have a problem with a custom template. The slider wont show properly in IE9 and below.

The first attachment shows how it should look, which works fine in chrome, firefox and safari.




The second attachment shows the mess in IE9




I have tried to track the problem down. However, the template was adapted from a standard template and I am getting lost in the stylesheet - I have not found any problems with numeric-multi so far and would be very thankful about any suggestions pointing me to the right direction.

Best regards
Steve
Attachments:
Last Edit: 4 years 6 months ago by Xtale.

Please Log in to join the conversation.

More
4 years 6 months ago #84791 by tpartner
Steve, can you attach a zipped copy of the template and a sample survey?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 6 months ago #84794 by Xtale
of course - thank you in advance :)
Attachments:

Please Log in to join the conversation.

More
4 years 6 months ago #84796 by tpartner
I've only tested in IE9, but in template.css (line 70), comment out or remove this line:
.ie .ui-slider{display:inline;}

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 6 months ago #84802 by Xtale
thank you very much! I was not familiar with conditional classes - learning never stops :lol:

Please Log in to join the conversation.

More
4 years 6 months ago #84804 by DenisChenu

tpartner wrote: I've only tested in IE9, but in template.css (line 70), comment out or remove this line:

.ie .ui-slider{display:inline;}

Oups ...
Seem a citronade bug. Can you look with default citronade ?
Thanks.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 6 months ago #84811 by Xtale
works for me with the default citronade and 1.92.

Maybe an unfortunate incident of bad template modification.

Please Log in to join the conversation.

More
4 years 6 months ago #84822 by DenisChenu

Xtale wrote: works for me with the default citronade and 1.92.

Thanks,

I've some little adaptation for citronade, put this in, not urgent ;).

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form