Using Array Filter : Am I doing it right?

More
4 years 11 months ago - 4 years 11 months ago #83910 by utsi
utsi created the topic: Using Array Filter : Am I doing it right?
This is what I want to achieve:
  • Question 1: User chooses answers from a set of multiple choice options (Mon, Tue, Wed, Thur, Fri, Sat, Sun) // Tue, Wed, Sat checked by user

  • Question 2: Show only those answers which were selected in 'Question 1' (Tue, Wed, Sat)

This is what I'm doing:
  • Question 1 'Code' is Q1
  • I added seven multiple choice options ranging from 'Mon' to 'Sun'
  • Saved the question

  • Question 2 'Code is Q2
  • Under 'Advanced Settings', I put in 'Q1' for 'Array Filter' field
  • I added same seven multiple choice options ranging from 'Mon' to 'Sun'
  • Saved the question


But on running the survey, only the options selected in Q1 are not showing up in Q2. All options are visible in Q2

Am I missing something?

Thanks,
Safdar
Last Edit: 4 years 11 months ago by utsi.

Please Log in to join the conversation.

More
4 years 11 months ago #83913 by utsi
utsi replied the topic: Using Array Filter : Am I doing it right?
Argh! I don't know why this happens. But soon after I post here, I somehow manage to find the solution myself. I was using wrong subquestion code in Q2.

Please Log in to join the conversation.

More
4 years 11 months ago #83919 by Mazi
Mazi replied the topic: Using Array Filter : Am I doing it right?
Common mistake. When using Array Filter the question code has to be correctly entered at the advanced question settings of the following question AND all the question codes need to be similar.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now