Page Breaks not working in printable version

More
5 years 4 months ago - 5 years 4 months ago #83324 by CrlyWrly
CrlyWrly created the topic: Page Breaks not working in printable version
I have added one page break as a test, to the first question in my survey.

When I preview the survey before printing, there is no page break.


I could not find any reference to this as a problem in the forums or the bug tracker.

Is there a way to force a page break?

If so, would it also be possible to insert a page break after the "Welcome" message? Would you do this by inserting a Question with no options for answers and enable the "page break" option in Advanced Settings for the Question?

If relevant:
Best wishes,
Liz
Last Edit: 5 years 4 months ago by CrlyWrly.

Please Log in to join the conversation.

More
5 years 4 months ago #83327 by holch
holch replied the topic: Page Breaks not working in printable version
I found this here in the forum, maybe it helps:
www.limesurvey.org/forum/design-issues/6...breaks?lang=de#64042

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: CrlyWrly

Please Log in to join the conversation.

More
5 years 4 months ago #83335 by CrlyWrly
CrlyWrly replied the topic: Page Breaks not working in printable version
Thanks Holch :-)


Should I add
.pagebreak{page-break-after: always;}

to the bottom of the file print_template_css ?

I have copied the original template and thought at first that I should be adding that to the template file . . .

Do I add

<br class="pagebreak">

to the main template file?

Or is there an option to add this in the normal survey design interface that I just haven't noticed?

Many thanks again for the help,
Liz

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!