Check out the LimeSurvey source code on GitHub!

Relevance equation not working with array question type

More
4 years 6 months ago #82794 by Xtale
Hello,

I don't know if its a bug or if Im missing something. Controlling the visibility with !empty(question1) does not work if the previous question involves an array question type - the relevance equation just gives me "undefined variable" ??

Warm regards
x

Please Log in to join the conversation.

More
4 years 6 months ago #82798 by TMSWhite
See the naming conventions for EM . There isn't currently a function to say "is any part of an array question answered". Instead, you must check each individual variable. So if the variable is "q1", and sub-questions are "sq1-sq5", variable names are q1_sq1, q1_sq2, ..., q1_sq5.

Please Log in to join the conversation.

More
4 years 6 months ago #82809 by Xtale
thank you

Please Log in to join the conversation.

More
4 years 6 months ago #82828 by Mazi

Xtale wrote: thank you

You're welcome :-)

If our hints have been helpful and you enjoy limesurvey please consider a donation to give Limesurvey a future .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form