Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Issue when starting automatically a survey

Issue when starting automatically a survey 4 years 3 months ago #80898

  • bobbox
  • bobbox's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hello,

My survey is tested and ready to go online.
I set a start date and an end date as in the picture below (sorry, it's italian, but I think it's easy to understand):


but when the time has come, nothing happened and the survey didn't start. I had to start it manually.

The server settings seems to be ok so that there are no differences between server time and client time.



PHP info says that calendar is activated.

Is anyone having the same issue? Do I have to check some other server settings?

It sounds strange, because it worked when older versions of limesurvey were used.

Many thanks for your support
Last Edit: 4 years 3 months ago by bobbox.
The administrator has disabled public write access.

Issue when starting automatically a survey 4 years 3 months ago #80902

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9305
  • Thank you received: 1330
  • Karma: 386
Just quick.

Your survey is activated ?

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Issue when starting automatically a survey 4 years 3 months ago #80906

  • bobbox
  • bobbox's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
DenisChenu wrote:
Just quick.

Your survey is activated ?

Denis

at the moment yes. I had to start the survey for a project at 9:30 today (local time), but I did it manually, because the settings (start date and hour) I saved (9:30) in the system did nothing.
At 9:35 the survey was displayed as inactive despite the start date saved in survey settings.
The administrator has disabled public write access.

Issue when starting automatically a survey 4 years 3 months ago #80908

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9305
  • Thank you received: 1330
  • Karma: 386
Hello,

Start date/time work only for activated survey.

You have to activate survey, set a start date/time.

Then user can have access only when start date/time is come.

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Issue when starting automatically a survey 4 years 3 months ago #80913

  • bobbox
  • bobbox's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
DenisChenu wrote:
Hello,

Start date/time work only for activated survey.

You have to activate survey, set a start date/time.

Then user can have access only when start date/time is come.

Denis

Many thanks for your reply.
Just tested and it works following the process you described.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.287 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form