Check out the LimeSurvey source code on GitHub!

Edit index.php page

More
4 years 9 months ago - 4 years 9 months ago #80750 by IoSmith
Hello all.
I would like to edit the page where all publicy listed surveys are available and insert my logo.

Moreover, i would like to change the favicon. I tried the obvious to replace the "favicon.ico" file in \limesurvey\admin with no results.
Attachments:
Last Edit: 4 years 9 months ago by IoSmith.

Please Log in to join the conversation.

More
4 years 9 months ago #80763 by tpartner
1) The survey-list page can be modified using the template editor. Copy your desired template and edit the copy.

2) Replace the favicon in the template (and bear in mind that some browsers "remember" favicons for a long time so test for changes in another browser).

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 9 months ago #80771 by DenisChenu

tpartner wrote: 1) The survey-list page can be modified using the template editor. Copy your desired template and edit the copy.

And choose your template in general settings :)

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 9 months ago - 4 years 9 months ago #80786 by IoSmith
Thank you both. I had already done the proposed changes.
I noticed that although i use a copy_of_citronade template in my survey, the survey-list page (limesurvey/index.php) uses the default (you can see it in the attachment in previous message).
So i had to change it: Global Settings->General->Default Template->set the copy_of_citronade.
Last Edit: 4 years 9 months ago by IoSmith. Reason: solved

Please Log in to join the conversation.

More
4 years 9 months ago #80787 by tpartner
That is not a bug, it is expected behaviour.

There are two settings for templates, one for the survey and one for the site.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 9 months ago #80788 by IoSmith

tpartner wrote: That is not a bug, it is expected behaviour.

There are two settings for templates, one for the survey and one for the site.


You are right! I've changed my message...

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form