Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:
  • Page:
  • 1
  • 2

TOPIC: Change "next" button to "I agree" button

Change "next" button to "I agree" button 2 years 2 months ago #110306

  • danika
  • danika's Avatar
  • Offline
  • Senior Lime
  • Posts: 53
  • Thank you received: 1
  • Karma: 0
Tony, thanks. But the server does not seem to like this. When I use this, I get the message: "Forbidden

You don't have permission to access /survey/index.php/admin/database/index/updatesurveylocalesettings on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

The problem seems to be whenever I try to add objects such as buttons the server objects. The host has addressed the com_security issue, and I do have XSS turned off. However, when I used your code from your earlier suggestion here and placed that within the welcome.pstpl, it worked. Would there be something you can suggest using this method in welcome.pstpl, which seems to work fine?

Thanks again
Last Edit: 2 years 2 months ago by danika. Reason: formatting
The administrator has disabled public write access.

Change "next" button to "I agree" button 2 years 2 months ago #110307

  • tpartner
  • tpartner's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 6238
  • Thank you received: 1382
  • Karma: 539
Sorry, I have no idea what's happening to cause the error. My code is strictly client-side so should have no impact on the server.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Change "next" button to "I agree" button 2 years 2 months ago #110309

  • danika
  • danika's Avatar
  • Offline
  • Senior Lime
  • Posts: 53
  • Thank you received: 1
  • Karma: 0
No worry. But, would there be an equivalent of what you posted above to use in welcome.pstpl, which seems to work just fine as opposed to posting it in the Welcome text?

Cheers
The administrator has disabled public write access.

Change "next" button to "I agree" button 2 years 2 months ago #110310

  • tpartner
  • tpartner's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 6238
  • Thank you received: 1382
  • Karma: 539
You should be able to use the same script there.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Change "next" button to "I agree" button 2 years 2 months ago #110311

  • danika
  • danika's Avatar
  • Offline
  • Senior Lime
  • Posts: 53
  • Thank you received: 1
  • Karma: 0
I tried. Server had no problem with your original suggestion. But, doesn't like this one for some reason. I am looking at how I might modify that right now and see if I can get it to work. Will post back if successful.
The administrator has disabled public write access.

Change "next" button to "I agree" button 2 years 2 months ago #110312

  • danika
  • danika's Avatar
  • Offline
  • Senior Lime
  • Posts: 53
  • Thank you received: 1
  • Karma: 0
If it matters, I am trying this with the Vallendar template.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.289 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form