Setting up quota's with hidden question filled by prefilled URL answer

More
5 years 3 months ago - 5 years 3 months ago #74157 by dspaan
dspaan created the topic: Setting up quota's with hidden question filled by prefilled URL answer
Hi,

Before i posted here i looked at least 10 topics regarding quota's, i've read the manual and afaik i've done everything correctly.

I have created a survey that is done by telephone. We use VICIdial for that and have created a token based survey with the lead_id's from VICIdial. Once the agent gets someone on the phone and clicks the webform link it calls this URL to start the survey:
http://192.168.1.201/limesurvey/index.php?sid=88938&88938X1X1=--A--uitvoerder--B--&lang=nl&token=--A--lead_id--B--

It starts the proper survey with the proper token and also the question i have prefilled is saved. I used this instruction to do that.

This survey is about the customer satisfaction of a service desk where the quotas are limited to each of the 5 employees who work there. I have received abbreviations for these 5 employees:

mdz
pma
pvb
slo
xmsp

In the sample file which i loaded in VICIdial each respondent that is called has one of the above codes specified which i pass along as an answer to the first question via the survey URL. This question is set to be hidden and is a drop-down list question.

I noticed that the quota's aren't working. I added a testing quota on another question and that worked immediately. See screenshot.




What could be causing this, the fact that it's a hidden question? The fact that i'm inserting the answer by URL or that it's a drop-down list (should work according to manual).

The survey is already activated, how can i still manage quota's? Only workaround i can think of at this point would be to manually monitor the number of interviews for each code and communicate to the agents to stop calling those numbers when the limit is reached.
Attachments:
Last Edit: 5 years 3 months ago by dspaan.

Please Log in to join the conversation.

More
5 years 3 months ago #74162 by holch
holch replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
How did you hide the question? Is it via CSS or via the function in the advanced settings of the question? I think if it is the one from the advanced settings, there can be problems. Try to "unhide" the questions and give it a try and see what happens.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 3 months ago #74200 by dspaan
dspaan replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
Yes, i used the advanced settings. The survey is active so i can't change that right? Can i set it to inactive, change it and then to active again without consequences?

Please Log in to join the conversation.

More
5 years 3 months ago #74215 by Mazi
Mazi replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
You can change the "always hide this question" setting even if the survey is activated. Then try hiding the question using CSS (display: none).

This might make a difference because when using the "always hide this question" setting, no HTML for the question is generated at all while the CSS solution just hides the HTML.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 3 months ago #74287 by dspaan
dspaan replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
Hi Mazi,

I must be overlooking an option but can't find a way to change the properties of the questions? I've read this but still don't understand how to edit the questions after activation. docs.limesurvey.org/Changing+an+active+s...tions+for+LimeSurvey

What is the location and name of the CSS file do i have to edit?

Please Log in to join the conversation.

More
5 years 3 months ago #74292 by holch
holch replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
Which CSS file it is depends very much on the template you are using. Usually it should be the standard CSS file for your template.

Then you have a look at the classes and IDs given to the respective question and apply a display:none to this class/ID

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 3 months ago - 5 years 3 months ago #74304 by tpartner
tpartner replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
Add the following to the end of template.css where "QQ" is the question ID .
#questionQQ {
	display: none;
}

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 5 years 3 months ago by tpartner.

Please Log in to join the conversation.

More
5 years 3 months ago #74305 by dspaan
dspaan replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
Thanks for the quick replies. I'm using the default template for this survey.

How do i find out the ID's of the questions once the survey is locked?
I edited /limesurvey/templates/default/template.css but don't see the questions in there?

Also how do i do this:

You can change the "always hide this question" setting even if the survey is activated.

Please Log in to join the conversation.

More
5 years 3 months ago #74311 by tpartner
tpartner replied the topic: Setting up quota's with hidden question filled by prefilled URL answer

How do i find out the ID's of the questions once the survey is locked?



Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Attachments:

Please Log in to join the conversation.

More
5 years 3 months ago #74336 by dspaan
dspaan replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
Gawd, why did i make a fool of myself... :blush:
I was trying to find an option in the left side of the menu to alter the questions while i just had to use the dropdown menu's on the right just like i did when creating the survey. Guess i have to get used to the interface hehe.

Anyway, i just decided that the agents will fill out the first question instead of making it invisible. I noticed that the quota's work as intended that way.

Please Log in to join the conversation.

More
5 years 3 months ago #74386 by Mazi
Mazi replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
So once you got that working smoothly it would be nice if you posted your complete solution with some comments here so others can benefit from your findings as well.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 3 months ago #74394 by dspaan
dspaan replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
You mean the VICIdial part?

Please Log in to join the conversation.

More
5 years 3 months ago #74441 by Mazi
Mazi replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
The "Setting up quota's with hidden question filled by prefilled URL answer" part.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 3 months ago #74465 by dspaan
dspaan replied the topic: Setting up quota's with hidden question filled by prefilled URL answer
Like i said, didn't have time anymore to go deeper and get that working so i changed the answer to be filled out by the agent.

But if i we get another project that needs this i will give it another shot and post my findings here.

Please Log in to join the conversation.

More
4 years 11 hours ago #96311 by ViliLe
ViliLe replied the topic: Setting up quota's with hidden question filled by prefilled URL answer

Mazi wrote: You can change the "always hide this question" setting even if the survey is activated. Then try hiding the question using CSS (display: none).

This might make a difference because when using the "always hide this question" setting, no HTML for the question is generated at all while the CSS solution just hides the HTML.


I'm having the same problem as OP. I tried the above solution, but it doesn't work. It's not that the quota doesn't work, but that my Expression Manager code that is supposed to preset the value of a list type question doesn't seem to work if the question is invisible, regardless of whether this invisibility is achieved through "always hide this question" or CSS.

As a workaround, I think I will try to craft CSS that makes the question quite invisible to the human reader without actually touching the visibility attribute.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now