Check out the LimeSurvey source code on GitHub!

date format for the ENTIRE system...

More
5 years 1 month ago #71264 by PartieHonteuse
Hello,

I'm curious about the date format in the email templates and the "printanswers.php" file.

For the survey in question I have set the date format to MM-DD-YYYY and that works for any date input type questions but when the results are emailed and when the user prints the results (or exports to PDF from same screen) the date is in DD/MM/YYYY for the "Date Submitted" section, and I also have a question that asks "Start Date" which takes the format of DD.MM.YYYY, neither of which follow the survey settings of MM-DD-YYYY.

I'm running Version 1.91+ Build 11379.

Any assistance, please?

Thanks in advance,

Partie

Please Log in to join the conversation.

More
5 years 1 month ago #71845 by Mazi
This sounds like a bug at the date converter.

Please test if the problem still exists at the latest release . If so please open a ticket at the Bugtracker and...
  1. Give as much information as possible
  2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.
  3. Provide step-by-step instructions how to reproduce the problem.
  4. If possible/helpful please provide screenshots

Afterwards please post the link to the Bugtracker so we can follow the progress.

Thanks!


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 3 days ago #75004 by misterdot
Partie,
Not sure if you're still having this problem, but we ran in to it as well in Version 1.91+ Build 12416. The date format in the detailed admin notification and print answers is DD.MM.YYYY, which does not obey our global date setting of MM/DD/YYYY.
The workaround is to change line 1830 of common_functions.php:
function getextendedanswer($fieldcode, $value, $format='', $dateformatphp='d.m.Y'
In our case, changing the format to m.d.Y change both admin email and print answers.
Mazi, do you want me to open a bug?
-Matt

Please Log in to join the conversation.

More
5 years 4 hours ago #75274 by Mazi

misterdot wrote: The workaround is to change line 1830 of common_functions.php:

function getextendedanswer($fieldcode, $value, $format='', $dateformatphp='d.m.Y'
In our case, changing the format to m.d.Y change both admin email and print answers.
Mazi, do you want me to open a bug?
-Matt

Yes, please open a ticket at our bugtracker!


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 11 months ago #75315 by misterdot

Please Log in to join the conversation.

More
4 years 11 months ago #75355 by Mazi
Thanks, we'll look into it.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form