Check out the LimeSurvey source code on GitHub!

"Submit" button says "Next" instead

More
5 years 2 months ago #71177 by che
Hello,

I'm working on a survey and have an issue that has not occurred before -- on the final page of the survey, the button says "Next" instead of "Submit" as it normally does. Has anyone else experience this?

Any ideas of the fix? My survey is here. Please enter "Test" in at least one open-ended field if you take the survey to offer input.

surveys.humaneresearch.org/index.php?sid=69892

Unfortunately, I need help soon!

Thanks in advance for your thoughts.

Best,
Che

Please Log in to join the conversation.

More
5 years 2 months ago #71178 by ausdendp
That survey is pretty slow for me to diagnose, but that usually occurs when there are conditional question on the last group. If the last group does not get shown, that results in a "next" instead of "submit" for the last group. I get around this by making the last group contain at least one question asked of every respondent.
The following user(s) said Thank You: che

Please Log in to join the conversation.

More
5 years 2 months ago #71181 by che
ausdendp, thank you for the response.

Yes, the survey is slow as it's a very complicated one. I should have noted that, sorry.

You helped me solve the issue, which was that I had an extra group at the end with no questions in it. This should have been obvious... but you led me in the right direction and I appreciate it.

Thanks,
Che

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form