Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Favicon

Favicon 4 years 8 months ago #70487

  • renu81072
  • renu81072's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 19
  • Karma: 0
Have removed the default favicon and replaced with the favicon i need to display in my survey... But does not seem to be working.. Have included the code before </head>

script type="text/javascript" src="{TEMPLATEURL}template.js"></script>
<link rel="shortcut icon" href="{TEMPLATEURL}favicon.ico" />

But does not seem to be changing... Have even removed these icons in the respective directory and replaced with the one I want.. No Luck.. Where Could I be going wrong.. Am using version 1.91+
Thanks..
The administrator has disabled public write access.

Favicon 4 years 8 months ago #70491

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
Hello,

In general, favicon are in the cache for a lon long time.

Try with another browser.
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Favicon 4 years 8 months ago #70502

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5984
  • Thank you received: 368
  • Karma: 260
Instructions on how to change the favicon can be found here: docs.limesurvey.org/The+template+editor&...splay_custom_favicon

You have to clear the browser cache so that the new icon is loaded and not the old one from the cache.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Favicon 4 years 8 months ago #70525

  • renu81072
  • renu81072's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 19
  • Karma: 0
Its weird that my favicon gets displayed properly in Mozilla but even though have cleared cache in IE (actually each restart clears the cache) but the favicon remains the same.... :(
Thanks.. Renuka
The administrator has disabled public write access.

Favicon 4 years 8 months ago #70528

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6212
  • Thank you received: 1376
  • Karma: 539
As Shnoulle says, favicons are cached for a long time, particularly in IE, and not in the temporary internet files. It may take many restarts before you see the updated favicon in IE. Check it in IE on another computer.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 4 years 8 months ago by tpartner.
The administrator has disabled public write access.

Favicon 4 years 8 months ago #70639

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
Yep,

And even after clear the chache , check directly (and see) the new icon with mysqiteurl/favicon.ico : favicon in toolbar stay the old fav (with FF).

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Favicon 4 years 8 months ago #70647

  • renu81072
  • renu81072's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 19
  • Karma: 0
Have checked directly.. the favicon displayed on the page is the one i want.. But in the favicon place IE logo is seen... whereas in Mozilla this shows in both the places...

Thanks... Renuka
The administrator has disabled public write access.

Favicon 4 years 8 months ago #70648

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6212
  • Thank you received: 1376
  • Karma: 539
That is a browser issue, not a LimeSurvey problem.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Favicon 4 years 8 months ago #70649

  • renu81072
  • renu81072's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 19
  • Karma: 0
Hmmm... So there is no option to get my favicon displayed... :(

Regards
The administrator has disabled public write access.

Favicon 4 years 2 months ago #82732

  • vsc
  • vsc's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
You need to clear the cache from IE manually. Go to C:\Users\USERNAME\AppData\Local\Microsoft\Windows\Temporary Internet Files and clear the favicon.ico. restart IE and it will work. The AppData folder is not visible. you need to enable the hidden folder.
The administrator has disabled public write access.

Favicon 4 years 1 month ago #82857

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5984
  • Thank you received: 368
  • Karma: 260

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.293 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form