Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Publishing issues

Publishing issues 5 years 6 months ago #61007

  • dgewin
  • dgewin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hi ... i've created a survey and the administrator has pointed dns at it (it is internal). The address is 111.235.130.57/index.php?sid=35399&lang=en and it shows the front page, but as soon as you click next, it reverts to looking for the internal address of the page (eg 10.8.1.xxx).

Really like to get this up and running for a local club.

Regards
David
The administrator has disabled public write access.

Publishing issues 5 years 6 months ago #61008

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5446
  • Thank you received: 814
  • Karma: 240
Sounds like a wrong server configuration to me.

So from where the survey should be accessed? From outside (internet)? Or from inside your local network?

Have you tried to use the IP address (111.235.xxx.xx) in the config for
$rooturl = "http://{$_SERVER['HTTP_HOST']}/limesurvey";
You would have to include something like
$rooturl = "http://111.235.130.57/limesurvey";

I am not an expert in server configurations, but it seems that when Limesurvey tries to detect the Http_host it doesn't recognize the external IP but the internal IP. And this sounds to me like a problem in the configuration of the webserver. But as I said, I am not an expert...
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.

Publishing issues 5 years 6 months ago #61040

  • tpartner
  • tpartner's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 6574
  • Thank you received: 1477
  • Karma: 579
I think the $rooturl setting in config.php maybe ought to be:
$rooturl = "http://111.235.130.57/
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.
Time to create page: 0.257 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form