Welcome, Guest
Username: Password: Remember me

TOPIC: multi numeric - slider, inital value dont register

multi numeric - slider, inital value dont register 4 years 4 months ago #66717

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Well - I'll donate even if it takes more then 24 hours :-) I just hope I can have it working locally by sunday evening. Otherwise I must change the survey. Thanks for all the effort and attention you are putting in to this.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66732

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5839
  • Thank you received: 347
  • Karma: 261
I first (untested) fix was just released. You can test the updated file here: limesurvey.svn.sourceforge.net/viewvc/li...ision&revision=11094

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66735

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Fantastic news. I'll test it right away. Basically I'll just overwrite the old qanda.php?
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66736

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Okay - thanks. We are almost - but not quite there.

the issue with persistency / registration of the initial value seems to be resolved. But something has messed up the slider design. Se attached screenshot: Theres is an inputbox visible where there should only be a slider? I hope this explanation makes sense?
Attachments:
Last Edit: 4 years 4 months ago by lovepade.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66739

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5403
  • Thank you received: 1151
  • Karma: 479
I don't see that with the fix in IE or Firefox. Do you have any custom scripts running?

Can you please try with the attached survey in the default template?

File Attachment:

File Name: limesurvey...2781.lss
File Size:34 KB



Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66740

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Well - yes I still see the input boxes? just tried on firefox 7 and chrome 16. (mac os x).

Weird.

EDIT: I just got home and tried on chrome stable, linux. Still the input boxes show up. I tried with default template, limespired and eirenicon.

This is the culprit:
<input class="text" type="text" name="42781X224X27011" id="answer42781X224X27011" value="25"
">

I guess I can hide the input box with e.g.
#answer42781X224X27011 {
    display: none;
}
... but it's not very elegant :-)
Last Edit: 4 years 4 months ago by lovepade. Reason: codefix
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66743

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5403
  • Thank you received: 1151
  • Karma: 479
Can you activate a sample survey for me to test?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66764

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Hi tpartner,
I'd be glad to. This is the your own test survey, with the limespired template. skema.dzidzo.dk/42781/lang-en
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66768

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5839
  • Thank you received: 347
  • Karma: 261
Using the linked test survey I can reproduce the problem on Firefox 3.6:


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66785

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5403
  • Thank you received: 1151
  • Karma: 479
This is very odd, I can't reproduce this with the latest release (11102).

Marcel, can you reproduce on your system?

lovepade, did you update your whole <a href='www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey'>installation</a> or just quanda.php?

This is what I see:

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
Last Edit: 4 years 4 months ago by tpartner.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66791

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
I only updated qanda.php... As that seemed to be the only thing that was changed. I'll do a complete upgrade right away. Thanks again.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66796

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Just to be clear: Please confirm that this is the tarball that you would like me to download and install? limesurvey.svn.sourceforge.net/viewvc/li...y/source/limesurvey/ ?

I not used to browsing source files on SourceForge, sorry.
Last Edit: 4 years 4 months ago by lovepade. Reason: added request to confirm correct download
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66801

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5839
  • Thank you received: 347
  • Karma: 261
I only replaced the qanda.php file and it works fine here locally.

Update to the latest 1.91 version which can be donwloaded on sourceforge at sourceforge.net/projects/limesurvey/file.../download?_test=goal and then replace qanda.php afterwards.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
Last Edit: 4 years 4 months ago by Mazi.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66805

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
as per above, I already ran build 11026 (updated via 3 step automatic magic) before I replaced qanda.php? That is the latest version?

Edit: Just compared version.php of the installed and the latest file. I'm already running the latest version, automagically updated. I'll try to do a clean reinstall though. If I am the only one with this issue - something has to be amiss...
Last Edit: 4 years 4 months ago by lovepade.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 4 years 4 months ago #66806

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5403
  • Thank you received: 1151
  • Karma: 479
For some reason your version of lime-slider.js is outdated.

My version is "$Id: lime-slider.js 11045 2011-09-27 14:24:57Z shnoulle $", whereas yours is "$Id: lime-slider.js 9648 2011-01-07 13:06:39Z c_schmitz $" and appears to be missing the following line:
$('#answer'+basename).hide();

I don't know whether this was caused by updating but try replacing your /scripts/jquery/lime-slider.js with this version (remove the .txt extension).


File Attachment:

File Name: lime-slider.js.txt
File Size:4 KB
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
Last Edit: 4 years 4 months ago by tpartner.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.497 seconds