Response Table ID Number

More
6 years 2 months ago #59722 by jumper1449
jumper1449 created the topic: Response Table ID Number
Hello,

I have sent out a survey and starting to get responses. In the response data table the ID numbers run in order but only start at 6. I am wondering how I locate ID numbers 1-5? I was told that 1-5 were missing due to testing however, I re-sent the survey to myself (since I did during testing too) and my response did not come back as an ID number between 1 and 5.

I am working with version 1.85+ and very new all of this.

Please Log in to join the conversation.

More
6 years 2 months ago #59728 by holch
holch replied the topic: Response Table ID Number
I would also guess that those ID's where used during testing and later deleted, otherwise they should show up in the statistics section. Do you have maybe a screenshot or something?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 2 months ago #59745 by jumper1449
jumper1449 replied the topic: Response Table ID Number
I cant do a screen shot but it basically looks like this.

id
6
7
8
9
10

Please Log in to join the conversation.

More
6 years 2 months ago #59749 by holch
holch replied the topic: Response Table ID Number
The first 5 must have been deleted by someone using your installation. Probably those were links that have been tested, etc.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 2 months ago #59750 by jumper1449
jumper1449 replied the topic: Response Table ID Number
Ok. Is there anyway I can recover those links without deactivating the survey?

Please Log in to join the conversation.

More
6 years 2 months ago #59751 by holch
holch replied the topic: Response Table ID Number
Hmm, I have no idea. I fear, when they were actually deleted, then there might be no chance to get them back. But this very much depends on what exactly happened to them. At the moment it is not 100% clear to me.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
1 year 10 months ago #124042 by Oldencastle
Oldencastle replied the topic: Response Table ID Number
I have a similar question. The IDs in my response table look like this:

id
25
26
27
28
29
30
32
579
34
35
41
37
580
38
39
40
42
43
44
45
46

As you can see, some ids are missing (1-24, 31, 33, 36) others don't appear in the correct order (41, 579, 580). Any idea what could be causing this?

Please Log in to join the conversation.

More
1 year 10 months ago #124079 by tammo
tammo replied the topic: Response Table ID Number
Maybe this has to do with working with an ancient version of LimeSurvey. 1.85 is from years ago. Please try reproduce this behaviour in a newer version.


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in to join the conversation.

More
1 year 10 months ago #124080 by jelo
jelo replied the topic: Response Table ID Number

tammo wrote: Maybe this has to do with working with an ancient version of LimeSurvey. 1.85 is from years ago. Please try reproduce this behaviour in a newer version.

The poster hasn't stated which version is in the use.

There are few reasons, why the counter is showing such gaps.
Deactivating and activating the survey. Deleting answers. Reimporting Data.
Sometime the database configuration is forcing the counter to jump.
Mostly such issues can be ignored. As long as the ID isn't going backwards or a ID is occurring two times, it won't cause much trouble.

Please Log in to join the conversation.

More
1 year 10 months ago - 1 year 10 months ago #124094 by Oldencastle
Oldencastle replied the topic: Response Table ID Number
Thanks for the replies. I'm on version 2.05+ build 141229.

Deactivating and reactivating the survey could account for the 24 missing IDs at the beginning. No answers were deleted and I didn't reimport any data. I don't know how my database configuration could cause the counter to jump.

It's probably a non-issue. The IDs aren't going backwards and no ID is occuring more than once. Apart from the jumps in the IDs, the data seems to be fine.
Last Edit: 1 year 10 months ago by Oldencastle. Reason: Typo

Please Log in to join the conversation.

More
1 year 10 months ago #124097 by holch
holch replied the topic: Response Table ID Number
Do you offer the option to clean the form and leave the survey? In this case I would assume that the entry is deleted from the database, but as the ID is created when a survey has been started, it would be missing in your table (not sure though).

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
1 year 10 months ago #124101 by Oldencastle
Oldencastle replied the topic: Response Table ID Number
I think this might be it. Respondents were indeed given the option to clean the form and leave the survey. Yours is the best explanation for the missing IDs I got so far.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now