Welcome, Guest
Username: Password: Remember me

TOPIC: Question group shows in empty.

Question group shows in empty. 5 years 3 weeks ago #55487

  • c001os
  • c001os's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Hi!

I did my survey, each group of questions, the jump conditions. It's all right with the survey,but the blank question groups (what need to be skipped) is allways shows! What can i do?
The administrator has disabled public write access.

Question group shows in empty. 5 years 3 weeks ago #55496

  • Mazi
  • Mazi's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5843
  • Thank you received: 348
  • Karma: 261
1. Which Limesurvey version do you use?

2. Can you post a link t a test survey so we can have a look at this issue live?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
The following user(s) said Thank You: c001os

Question group shows in empty. 5 years 3 weeks ago #55501

  • c001os
  • c001os's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
My version: Verzió 1.90+ Build 9596

Test link: kutatas.panenerg.hu/index.php?sid=11187&newtest=Y&lang=hu

The Question what makes the jumps: Megújuló energia szektor releváns tevékenysége:

When you select "kivitelező", the survey dont jump directly to that question group... Before "kivitelező" question group some empty group shows on.
The administrator has disabled public write access.

Question group shows in empty. 5 years 3 weeks ago #55505

  • Mazi
  • Mazi's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5843
  • Thank you received: 348
  • Karma: 261
You have to activate the survey for tsting or change the preview setting at "global settings" -> "security" -> "preview".

Also have a look at the "$hide_groupdescr_allinone:" setting at docs.limesurvey.org/Optional+settings&st...rvey#Survey_Behavior

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
The following user(s) said Thank You: c001os

Question group shows in empty. 5 years 3 weeks ago #55510

  • c001os
  • c001os's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I changed the preview settings!

Tested the "$hide_groupdescr_allinone:" setting to false and back to true but nothing happend!
The administrator has disabled public write access.

Question group shows in empty. 5 years 3 weeks ago #55513

  • c001os
  • c001os's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
By the way i have no other problem so limesurvey is great! But i need to figure this out!
The administrator has disabled public write access.

Question group shows in empty. 5 years 3 weeks ago #55517

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5421
  • Thank you received: 1156
  • Karma: 480
You have several conditional questions in the second group. All of these questions must use the condition that hides the group. In other words, they need to have the condition that hides them within the group AND the condition that hides the whole group.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
The following user(s) said Thank You: c001os, avanoers

Question group shows in empty. 5 years 3 weeks ago #55518

  • c001os
  • c001os's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Ok, thanx, but i cant find a condition that hide a group, just a condition which hide a question. Where can i find the hide group condition?
The administrator has disabled public write access.

Question group shows in empty. 5 years 3 weeks ago #55519

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5421
  • Thank you received: 1156
  • Karma: 480
The condition used to hide "Milyen tervezői jogosultsággal rendelkezik Ön?" needs to be applied to all questions in that group.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
The following user(s) said Thank You: c001os

Question group shows in empty. 5 years 3 weeks ago #55520

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5421
  • Thank you received: 1156
  • Karma: 480
See copying conditions - docs.limesurvey.org/Setting+conditions&s...s_to_later_questions
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Question group shows in empty. 5 years 3 weeks ago #55522

  • c001os
  • c001os's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
It has been applied to all question.. therefore the group is empty... Or im doing something wrong?
Last Edit: 5 years 3 weeks ago by c001os.
The administrator has disabled public write access.

Question group shows in empty. 5 years 3 weeks ago #55524

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5421
  • Thank you received: 1156
  • Karma: 480
It appears to be working correctly now. The "Tervezői kérdések" group is now completely hidden if "Megújuló energia szektor releváns tevékenysége" = "kivitelező".
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
The following user(s) said Thank You: c001os

Question group shows in empty. 5 years 3 weeks ago #55525

  • c001os
  • c001os's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Yeah! Its perfect now!
The administrator has disabled public write access.

Question group shows in empty. 5 years 3 weeks ago #55526

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5421
  • Thank you received: 1156
  • Karma: 480
:cheer:
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Question group shows in empty. 5 years 3 weeks ago #55603

  • Mazi
  • Mazi's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5843
  • Thank you received: 348
  • Karma: 261
c001os wrote:
Yeah! Its perfect now!
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.212 seconds