2 part survey - connected

More
6 years 2 weeks ago #57963 by holch
If you use a survey with tokens then each token can only be used once, so you can't do the same survey again. You either have to provide different tokens or you have to make a survey without tokens.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: phschwager

Please Log in to join the conversation.

More
6 years 2 weeks ago #57966 by phschwager
Thanks, I think I figured out a way to make it work with 2 surveys. The first one uses tokens. Then in the Thank You for completing the first part e-mail I send them a link to the second part. The second part passes the token as a question answer so now I can tie the two parts together. It worked in a small version, now I just need to make the bigger surveys :-)

Here is the link where I found how to insert the variable. Just had to call the token variable.

docs.limesurvey.org/Workarounds%3A+Surve...using_the_survey_URL

Please Log in to join the conversation.

More
3 years 11 months ago #94820 by Lila86
Dear all,
basically, I have a very similar question as phschwager.
I want to measure the responses of the participants twice but need their responses to appear in one dataset so that their answers are connected.

My procedure looks like this:
I will e-mail the survey URL to selected participants - without using tokens. They finish the first part. After two or seven days, I will send them a reminder with the URL to the second part.
A lot of participants would be filling in the first and second part simultaneously. (Is the solution offered to phschwager then still possible?)

I have already tried to follow the suggested steps in this forum post, but it does not work properly and I do not know where the mistake lies.
- I have created 1 survey intented to include the two parts.(Survey ID=89882)
- I have created a Group=hidden question (ID=1424) with 1 MCQuestion=Measurementmoment with 1 answeroption = "part2" (ID=25466).
- Then I created a lot of questions for part one. With no conditions.
- Then I created conditions for all the questions that should only be seen in the second part.
I could either create a condition for the group (parts) or the MCQ answeroption (marked/not marked). So i defined two conditions to be sure.
1. Show Qx if Measurementmoment=part2
2. Show Qx if Measurementmoment:SQ001=marked.
In the end the Condition looks the same: Relevance: ((Measurementmoment_SQ001.NAOK == "Y") and (Measurementmoment_SQ001.NAOK == "Y"))
- Then I adapted the reminder URL as suggested by Mazi.
The first URL link send to participants ends like this: ?sid=89882&lang=nl
Accordingly, I thought the second URL should end like this: ?sid=89882&gid=1424&qid=25466=part2
I tried several versions of adding =part2 to the URL, but none works. Additionally, I get the message "this survey does not yet contain any questions".

Apparently, I must have made a mistake. But where? Can you help me?
Is it the URL?
Is it the HiddenQuestion? (Should i have chosen "Equation" as questiontype? If yes, what would the question field read?)
Is it the Condition?
Or is it a combination of all three?

Many thanks for your response and help!


PS: I am using lime-survey 1.92.

Please Log in to join the conversation.

More
3 years 11 months ago #94821 by Mazi
1. Can you attach your survey for testing?

2. The URL to the second part is wrong, it has to look like this (couldn't test yet):
?sid=89882&lang=nl&89882X1424X25466_SQ001=Y

Maybe this URL work, too:
?sid=89882&lang=nl&Measurementmoment_SQ001=Y


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 11 months ago #94825 by Lila86
Many thanks for such a quick response.

1. surveys-igs.utwente.nl/index.php?sid=89882&lang=nl (this would be the initial link)

I tried using the following URL, but it justs starts with the first question of the first part.
surveys-igs.utwente.nl/index.php?sid=898...rementmoment_SQ001=Y

Addtionally, I set the conditions for the first part of the survey only to show if: Relevance: ((Measurementmoment_SQ001.NAOK != "Y"))
But this did not work either.

Please Log in to join the conversation.

More
3 years 11 months ago #94831 by Mazi
The switch question ("Measurement..." has to be placed at the very beginning of the survey. You can't set a condition at question 2 based on the answer of a question on a following page which is usually not know/not defined.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 11 months ago #94837 by Lila86
The "measurement" question already is at the very beginning of the survey.
It's the following order:
Welcome message
Measurementmoment (hidden)
Part one questions - Randomisation, Attitude (conditioned)
Part two questions (conditioned)

Do you reckon the problem lies with defining the hidden question, or the conditioning? Since you have indicated how the 2nd URL should look like that should not be the problem, right?

Please Log in to join the conversation.

More
3 years 11 months ago #94838 by Mazi
Please attach the survey for testing.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 11 months ago - 3 years 11 months ago #94840 by Lila86
Can you see the file I uploaded?
Last Edit: 3 years 11 months ago by Lila86.

Please Log in to join the conversation.

More
3 years 11 months ago #94841 by Mazi
I see no file. Export it as .LSS file and then attach it here using the forum's editor.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 11 months ago #94842 by Lila86

File Attachment:

File Name: limesurvey...8821.lss
File Size:110 KB
Attachments:

Please Log in to join the conversation.

More
3 years 11 months ago #94846 by Mazi
I have imported the survey at my test server and made the multiple choice question non mandatory and visible:

Link for part 1:
limesurvey-templates.com/20/index.php/su...82/newtest/Y/lang/nl

Link for part 2:
limesurvey-templates.com/20/index.php/su...882X747X15053SQ001/Y

It works like a charm and the conditions seem to be correct as well.

Please note that I am using Limesurvey 2.0 which uses a different link syntax. At Limesurvey 1.92 the link to part 2 would look like:
limesurvey-templates.com/20/index.php?si...882X747X15053SQ001=Y


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 11 months ago #94865 by Lila86
Mazi, you really are one of a kind.
Many thanks for looking through the file and the MCQ. Apparently, the mistake lay probably in the mandatory field and definitely in the ending of the URL.
As a complete programming novelist, detecting the flaw would have been a hopeless journey for me.

Please Log in to join the conversation.

More
3 years 11 months ago #94866 by Mazi

Lila86 wrote: Mazi, you really are one of a kind.
Many thanks for looking through the file and the MCQ. Apparently, the mistake lay probably in the mandatory field and definitely in the ending of the URL.
As a complete programming novelist, detecting the flaw would have been a hopeless journey for me.

You're welcome :-)

If our hints have been helpful and you enjoy limesurvey please consider a donation to give Limesurvey a future .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

  • jbauer
  • jbauer's Avatar
  • Visitor
  • Visitor
3 years 8 months ago #98468 by jbauer
is it possible to have a two part survey in one survey instead of two? i think need something like a save point or something. ie. a participant finishes the first section of a survey then they are asked if they want to continue if they select yes the previous (part one) answers is saved in the database and cannot be removed.

Any thoughts?

Please Log in to join the conversation.