Check out the LimeSurvey source code on GitHub!

SQL syntax error

More
6 years 4 weeks ago #54480 by nerdy
Hello :)

I've been using LS 1.85 and it worked perfectly. ran the survey , collected responses did stats and all. now , a year later, when i try to access stats or export to application I get this error message " You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND language='en' ORDER BY sortorder, code' at line 1:SELECT * FROM `lime_labels` WHERE lid= AND language='en' ORDER BY sortorder, code" .

Please help! Thanks alot!

Please Log in to join the conversation.

More
6 years 4 weeks ago #54491 by holch
So you didn't change anything in your installation? It is still LS 1.85?

I have seen a similar complaint from two others in the forum this week. This sounds rather strange to me, because LS 1.85 doesn't just change itself. It also doesn't have the update feature of the newer versions (which you still have to trigger manually anyway).

So my assumption would be, that there was an update to the MySQL-Server by your host.

Which host are you with?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form