Check out the LimeSurvey source code on GitHub!

Urgent! Help needed on an error in SQL syntax

More
6 years 4 weeks ago #54378 by Shirley
I am new to limesurvey and I am not a programmer. I just created the survey, and tested it before i activated the survey. Everything was fine then, until I activated it and started clicking on the first question.

The question is very simple:

Which city are you living in?

1. Beijing
2. Shanghai
3. Guangzhou
4. Others
Only the ones that have chosen Shanghai (2) are supposed to pass.

This is what I get when I click on any of the options.

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND submitdate IS NOT NULL' at line 2:SELECT id FROM `survey_81264` WHERE (`81264X7X50` = 'A1' ) AND (`81264X7X50` = 'A3' ) AND (`81264X7X50` = 'A4' ) AND ( ) AND submitdate IS NOT NULL

Version 1.90+ Build 9290

I don't know what to do. I don't even know where to check..I have spent hours and hours working on designing the survey and it is supposed to be live now! Please, can someone help me with it?

Thanks so much!

Shirley

Please Log in to join the conversation.

More
6 years 4 weeks ago #54381 by holch
So I assume you used conditions to let only those pass that have chosen Shanghai, right?

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 4 weeks ago #54397 by Shirley
Yes, I used conditions. Every other question will only show up when Shanghai is selected. I didn't do anything about Beijing, Guangzhou or Others.

Did I do something wrong?

Thanks for your help!

Please Log in to join the conversation.

More
6 years 4 weeks ago #54399 by holch
I am not a developer, so the error messages doesn't say much to me.

What happens if you export the survey and import it again as a new survey? This should be something quick to do.

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 4 weeks ago #54404 by Shirley
I tried. It's really weird. I exported as a .lss file and imported. it doesn't recognize the file type.. So I tried .xml, and it said imported successfully, but I can't find any new survey in my survey list...

Please Log in to join the conversation.

More
6 years 4 weeks ago #54407 by holch
It didn't recognize the own file? Then there must be something seriously wrong in your survey. I can understand that a file might not work when it is from another application, but from the same one? hmm....

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 4 weeks ago #54410 by DenisChenu
Can you trye to use the database inspector with LimeSurvey ?

At the top toolbar.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
6 years 4 weeks ago #54411 by Shirley
That's what I thought, but this is the error message I get when I try to import:

This is not a valid LimeSurvey survey structure XML file.

Which doesn't make much sense as I exported it as an .lss file and was under the impression that you could upload .lss files.

Is there anyone I can talk to about this?

Please Log in to join the conversation.

More
6 years 4 weeks ago #54419 by Mazi
Make a backup of your survey and then delete the conditions you have set. Test again if there still is an error shown.

I suppose there is a wrong/invalid/incomplete condition at your survey which causes the SQL error.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 4 weeks ago #54433 by Shirley
Thank you all for the help... The survey seems fine now... I didn't really do anything and somehow it fixed itself I think!! magic!

Please Log in to join the conversation.

More
6 years 4 weeks ago #54449 by Mazi
Strange, I have never heard of such a magic before.

But as long as everything runs fine now...


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form