Check out the LimeSurvey source code on GitHub!

CSS Help for Public Statistics link

More
6 years 1 month ago #52843 by paulfiner
Hi

Could someone help me with the CSS needed to hide the link to the Public Statistics on the completed page?


I want to keep public statistics on but not let the respondents get to them, only my client.

Cheers

Paul

Please Log in to join the conversation.

More
6 years 1 month ago #52846 by Mazi
The link has it's own class "publicstatisticslink".

I didn't test but maybe something like this at the end of your template.css might do the trick:

.publicstatisticslink {
display: none;
}


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 10 months ago #57643 by paulfiner
Apologies for bringing this thread back to life but I still haven't been able to find the correct CSS to be able to hide the link to the Public Statistics.

This is important for people working with panel providers as they usually require a live link to see questions with quotas/screenouts. I do not want the respondents to see the statistics.

I tried Mazi's suggestion and any number of other combinations of CSS but nothing seems to hide the link.

Cheers

Paul

Please Log in to join the conversation.

More
5 years 10 months ago #57661 by paulfiner
I have finally found the CSS to do what I need and it turns out to be embarrassingly easy :blush:

For anyone interested in achieving this the CSS code needed is just:

#completed a {
display: none;}


Cheers

Paul

Please Log in to join the conversation.

More
5 years 9 months ago #58635 by thanasix
Hey paul,

the solution that you proposed doesn't work for me (LS Version 1.90+ Build 9642).

Although i have managed to hide the public statistics link once in version 1.82 with the following code:

a.publicstatisticslink {
display: none;
}

it doesn't seem to work now in v.1.90+.

any idea?

thanks

Please Log in to join the conversation.

More
5 years 9 months ago #58637 by paulfiner
Hi

That's strange as I am using the v1.90+ too. Which template are you using?

Please Log in to join the conversation.

More
5 years 9 months ago #58638 by thanasix
Paul, first of all thanks for your quick reply.

Now, I'm using a slightly customized copy of default template and i have pasted your code at the end of template.css. Should i put it in a particular place inside this file?

thanks again.

Please Log in to join the conversation.

More
5 years 9 months ago #58640 by paulfiner
I just placed it at the very end so I'm not sure what's going on.

You could try going through you survey and then when you get to the completed page take a look at the source HTML to see what's going on. Firefox and Safari both have good options for inspecting elements on the page.

Cheers

Paul

Please Log in to join the conversation.

More
5 years 9 months ago #58641 by tpartner
I've tested the following with the default template in 1.90 and it hides the link. Add it to the very end of template.css

Have you cleared your cache?

Try it with the shipped default template.
a.publicstatisticslink {
	display: none;
}

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
5 years 9 months ago #58644 by thanasix
Everything is fine after clearing the cache..
Thanks a lot for reminding me this tpartner and sorry for the disturbance!
Thanasis

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form