Check out the LimeSurvey source code on GitHub!

Survey dropping out and redirecting - HELP!

More
6 years 3 months ago - 6 years 3 months ago #51370 by safetypsychlist
I have juts spent 3 days developing a Survey and it seemed to work well. Execpt it kept timing out. Set Cookeis on the browsers (IE8) and this prob left. What came in its place is that about half way though the survey (at a point where the items are going from one question group to another) it just goes to a page that says

The following surveys are available:
No available surveys
Please contact ?????? for further assistance.

I urgently need this working. I am a novice when it comes to web servers etc. Please advise what I need to do. Am happy to have someone fix this for me at a reasonable fee.

Here is a link to the survey

lionsurveys.com/limesurvey/index.php?sid=51996&lang=en

I have also attached the lss file

Just went back to it and the cookie message has turned uo again., I cannot complete the survey. URGENT HELP REQUESTED.

Many Thanks

David G Broadbent
skype d.g.broadbent
Last Edit: 6 years 3 months ago by safetypsychlist.

Please Log in to join the conversation.

More
6 years 3 months ago #51380 by tpartner
I was able to complete the survey using Firefox.

What is your setting for "Session lifetime" (Global settings -> General)?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
6 years 3 months ago #51421 by safetypsychlist
The session life time I have set to 7200. Also changed to same in php.ini.

Prolems still exists. Having ISP chengae the Suhosin settings to 2000, which Carsten suggeste might do the trick. I pray so. Nothing else has worked!!

Please Log in to join the conversation.

More
6 years 3 months ago #51459 by safetypsychlist
Touch Wood, the complete removal of the Suhosin extention from my webserver seems to have done the trick. Did place a PHP.ini file in my root directory. That did not chnage the problem. Have left it there though to give greater control in the future.

Please Log in to join the conversation.

More
6 years 3 months ago #51471 by DenisChenu
Here is my suhosin configuration for my active LS:
suhosin.session.checkraddr	0	0
suhosin.session.cryptdocroot	On	On
suhosin.session.cryptkey	[ protected ]	[ protected ]
suhosin.session.cryptraddr	0	0
suhosin.session.cryptua	Off	Off
suhosin.session.encrypt	On	On
suhosin.session.max_id_length	128	128

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
6 years 3 months ago #51567 by Mazi
Suhosin often causes problems. The easist solution is to get rid of it or to tweak the configuration.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form