Check out the LimeSurvey source code on GitHub!

"*" before every question

More
6 years 4 months ago #50217 by servey
Hi guys, Do you know how i can get rid of the * before my questions using the mint idea based theme?
Looked in the coding and cant find it anywhere.

Thanks
Attachments:

Please Log in to join the conversation.

More
6 years 4 months ago - 6 years 4 months ago #50218 by jelo
docs.limesurvey.org/tiki-index.php?page=...mandatory_questions_
* Open the template editor
    * Create a copy of the template you wish to modify
    * Select the "template.css" file and search for the asterix class
    * Add the following line at the end of the asterix class".asterisk {display: none;}".
    * Save template.css
    * Clear your browser cache so that the edited template.css is reloaded and not taken from cache.
Last Edit: 6 years 4 months ago by jelo.

Please Log in to join the conversation.

More
6 years 4 months ago #50219 by servey
Do I search for "*"?

Please Log in to join the conversation.

More
6 years 4 months ago #50221 by jelo

Please Log in to join the conversation.

More
6 years 4 months ago #50223 by servey
I have searched for asterisk and it says not found on all my css sheets

Please Log in to join the conversation.

More
6 years 4 months ago #50225 by holch
OK, it seems like mint_idea doesn't have a class "asterisk" defined in the stylesheet. But the class is in the question.pstpl:
<span class="asterisk">{QUESTION_MANDATORY}</span>

So what you do is to create a class in the template.css and hide this class:
.asterisk {
display:none;
}

Or you could just remove the whole code above, so the asterisk doesn't show anymore. However, just to inform you: the asterisk is there to alert participants about mandatory questions. If you hide/delete it, there is no sign of the question being mandadory.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 4 months ago #50232 by jelo
If there is no asterisk defined in the css why is it then shown ;-)

Perhaps servey should read the linked stuff and if he/she still don't get rid of the red asterisk he/she should tell us which version build of limesurvey is used.

Please Log in to join the conversation.

More
6 years 4 months ago #50239 by servey
Thank-you. That worked

Please Log in to join the conversation.

More
6 years 4 months ago #50242 by holch
@Jelo: it shows, because it is included in question.pstpl.

But the class "asterisk" is not available in my template.css of mint_idea. Have a look at yours if it is there. Would be weired.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 4 months ago - 6 years 4 months ago #50290 by Grenadeh
I did exactly what the previous person was told to do (as there is no asterisk class in my template either) and this did not get rid of the asterisk.

Nevermind, I fixed it. For whatever reason none of the classes are defined in the template, they are in the startpage.pstpl
Last Edit: 6 years 4 months ago by Grenadeh.

Please Log in to join the conversation.

More
6 years 4 months ago #50292 by tpartner
Remove {QUESTION_MANDATORY} from question.pstpl.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
6 years 4 months ago - 6 years 4 months ago #50294 by holch
That is a really weird template. Is it one of the standard templates that come with Limesurvey?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Last Edit: 6 years 4 months ago by holch.

Please Log in to join the conversation.

More
6 years 4 months ago #50298 by jelo
Grenadeh wrote:

Nevermind, I fixed it. For whatever reason none of the classes are defined in the template, they are in the startpage.pstpl


What did you fix?

I have used the actual build and just added
.asterisk {
  display: none;
}

to the template.css of mint_idea. I cleared the cache from the browser (very important when css html is changed) and reloaded the survey. The asterisk is hidden.

So no mystery thing with mint_idea.

Please Log in to join the conversation.

More
6 years 4 months ago #50314 by Grenadeh
My company uses a template that was written before I got here (unfortunately) and the asterisk class was never defined anywhere, nor is it even referenced for mandatory questions .

I defined the asterisk class in the survey.pstpl page, added code to hide the asterisk in the css template, cleared my cache, and it worked.

Now if only I could so easily remove bullet points before all questions with multiple answer options/subquestions.

Please Log in to join the conversation.

More
6 years 4 months ago #50316 by holch
Search in the forum, this came up just this week and there was a solution provided.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form