Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: time_limit_disable_next problem

time_limit_disable_next problem 5 years 9 months ago #49956

  • sestdiena
  • sestdiena's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hello,

When I am using time_limit_disable_next attribute, the timer starts countdown when the first page of survey have been opened, but I would like to start it when the page where it is located is open, but not at the start of whole survey.

The second problem is that it automatically moves to next question, is it possible to disable this feature?
Last Edit: 5 years 9 months ago by sestdiena.
The administrator has disabled public write access.

time_limit_disable_next problem 5 years 9 months ago #50044

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9293
  • Thank you received: 1327
  • Karma: 384
I test the time_limit_disable_next, and time start at the question with time limit page.

But there is a problem whe testing : counter aren't empty at restarting the survey.

Try to clean the cookies in your browser.
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

time_limit_disable_next problem 5 years 9 months ago #50540

  • coan
  • coan's Avatar
  • Offline
  • Premium Lime
  • Posts: 3
  • Karma: 0
Hi there,
Kind of related to this topic.

I’m having troubles using the time_limit function on two short text answers. The question seems to work fine, but after the time limit expires for the questions (for example when I test the question with preview function, or answer the questions when doing the survey), the time limit doesn’t reset. That is, once the time limit has expired for one participant on a question, the timer isn’t reset for the next participant. Instead the time_limit_message is showed. This problem occurs when the survey is organized by groups (with one question in each group) and when it’s organized questions by questions, and whether tokens are enabled or not. I’ve reproduced this problem with all of the available templates, and on two different servers.
However, when I clean the cookies in my browser (firefox and chrome), as suggested here, the timer works fine. Is there a way around this problem that doesn’t involve clearing their cookies before answering the questions?

I’m using LimeS 1.9, build 9169.
The administrator has disabled public write access.

time_limit_disable_next problem 5 years 9 months ago #50551

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9293
  • Thank you received: 1327
  • Karma: 384
You can send a report to the bug report.

;)
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

time_limit_disable_next problem 5 years 9 months ago #50556

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5974
  • Thank you received: 366
  • Karma: 260
coan wrote:
Hi there,
Kind of related to this topic.

I’m having troubles using the time_limit function on two short text answers. The question seems to work fine, but after the time limit expires for the questions (for example when I test the question with preview function, or answer the questions when doing the survey), the time limit doesn’t reset. That is, once the time limit has expired for one participant on a question, the timer isn’t reset for the next participant. Instead the time_limit_message is showed. This problem occurs when the survey is organized by groups (with one question in each group) and when it’s organized questions by questions, and whether tokens are enabled or not. I’ve reproduced this problem with all of the available templates, and on two different servers.
However, when I clean the cookies in my browser (firefox and chrome), as suggested here, the timer works fine. Is there a way around this problem that doesn’t involve clearing their cookies before answering the questions?

I’m using LimeS 1.9, build 9169.
Please open a ticket at the bugtracker and...

1. Give as much information as possible

2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.

3. Provide step-by-step instructions how to reproduce the problem.

4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

time_limit_disable_next problem 5 years 8 months ago #51619

  • coan
  • coan's Avatar
  • Offline
  • Premium Lime
  • Posts: 3
  • Karma: 0
The administrator has disabled public write access.

time_limit_disable_next problem 5 years 8 months ago #51622

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5974
  • Thank you received: 366
  • Karma: 260
Thanks, we'll look into it.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
Last Edit: 5 years 8 months ago by Mazi.
The administrator has disabled public write access.

time_limit_disable_next problem 5 years 8 months ago #51667

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9293
  • Thank you received: 1327
  • Karma: 384
Fixed in 9396.

I put the 3 files to the bug report
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
Last Edit: 5 years 8 months ago by DenisChenu.
The administrator has disabled public write access.

time_limit_disable_next problem 5 years 8 months ago #51669

  • coan
  • coan's Avatar
  • Offline
  • Premium Lime
  • Posts: 3
  • Karma: 0
Thanks, we will donate! I'll test the solution asap.
The administrator has disabled public write access.

time_limit_disable_next problem 5 years 8 months ago #51675

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5974
  • Thank you received: 366
  • Karma: 260
@Shnoulle: Thanks for fixing bugs!

@coan: Thanks for donating and reporting bugs!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.293 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form