Check out the LimeSurvey source code on GitHub!

Removing a field from question

More
6 years 8 months ago #41205 by VickiKnisely
When you enter a Yes/No question, the survey tool automatically generates a field for "no answer". How can I remove that answer?

Please Log in to join the conversation.

More
6 years 8 months ago #41217 by holch
You could just use a normal question and put yes and no as items, how about that?

By the way, when I create a yes/no question, at least in the preview, there is no "no answer" item.

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 8 months ago #41229 by tpartner
It can be disabled in the Global settings -> Miscellaneous screen.

The "No Answer" option will appear if the question is non-mandatory and it is enabled in Global settings -> Miscellaneous.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
6 years 8 months ago #41231 by holch
Ha, learned something new too. Must have switched this off somehow... ;-)

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 1 week ago #55024 by VickiKnisely
I was going back around to the "hide" the "No Answer" button. It is a standard field in all the answer strings. Even the array questions. Is there a way to hide that on all questions? Is this in the template editor anywhere?

Thanks!

Please Log in to join the conversation.

More
6 years 1 week ago #55026 by holch
The "No answer" option appears for all mandatory questions, right?

To switch this off go to "Global settings" -> "Miscellaneous" -> "Show 'no answer' option for non-mandatory questions: NO"

That should solve your problem.

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 6 days ago #55070 by VickiKnisely
I realize that this is a very basic question, and I apologize for that. I do not see in the documentation or in the survey structure where the "Global Setting" functions are located? Is that a programming item? Is it in the "Templates" area?

Thanks!

Please Log in to join the conversation.

More
6 years 6 days ago #55072 by VickiKnisely
Nevermind - you have to be a "super administrator" to complete this function.

Please Log in to join the conversation.

More
6 years 6 days ago #55073 by holch
Exactly, so you managed to change this, I assume?

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: VickiKnisely

Please Log in to join the conversation.

More
6 years 6 days ago #55095 by VickiKnisely
Yes - we got the field updated and it is working as we wanted.

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form