Check out the LimeSurvey source code on GitHub!

Spacing issues with questions

More
6 years 10 months ago #40223 by blowe46
Hi

There's a gap between my question and the phrase "choose one of the following answers". Furthermore, it is consistent between each question. Is there anyway to change the gap?

Can I simply delete the phrase "choose one of the following answers?"

thanks

Please Log in to join the conversation.

More
6 years 10 months ago #40237 by tpartner
The spacing is probably caused by extra line breaks in the editor.

You can remove the phrase for each question by setting "Hide tip" to yes.

If you want to remove it from all questions, add the following to the end of template.css:
span.questionhelp {
	display: none;
}

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
6 years 10 months ago #40287 by holch
I just came by, but now there came up a question I always wanted to know. Can you overwrite this default question help text somehow?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 10 months ago #40288 by VBraun
It should be possible in language file

Please Log in to join the conversation.

More
6 years 10 months ago #40289 by holch
Well, yeah, I could always go into the hard code as well. ;-)

Usually the default text is fine, but then sometimes, for specific questions, you might want to change it, just for this specific question in this specific questionnaire.

When I do it in the language file it will show up in all other questions of the same type, not only in the current questionnaire, but in all questionnaires, or am I wrong?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 10 months ago #40299 by tpartner
Adding the following to a template.js file will change the text for only the surveys using that template.
 
	$(document).ready(function() {
		$('.list-radio span.questionhelp').text('Some new help text for radios.');
		$('.list-dropdown span.questionhelp').text('Some new help text for dropdowns.');
	});

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
6 years 10 months ago #40372 by Mazi
holch wrote:

I just came by, but now there came up a question I always wanted to know. Can you overwrite this default question help text somehow?

In general there is no other possibility then the ones mentioned. There is a help text section when adding a question so these auto-added texts are not that useful, that's why we implemented a question attribute to get rid of it.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 6 days ago #56923 by ckwill90
I noticed this too. It seems the <p> tag has been added to some questions. I had to edit my questions using the advanced options and viewing the source.

Please Log in to join the conversation.

More
6 years 6 days ago #56928 by Mazi

ckwill90 wrote: I noticed this too. It seems the <p> tag has been added to some questions. I had to edit my questions using the advanced options and viewing the source.

Can you try to find out at which question types these <p> tags are added by Limesurvey so we can try to debug and fix this annoying behavior!?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 6 days ago #56934 by ckwill90
I used both multiple options and list radio. The <p> tags were included on only some of the questions using either question type. This is the first survey I've created. I've reviewed all questions to see if I could find some type of similarity to help troubleshoot but did not see anything obvious. If I notice some type of pattern I will post back.

Please Log in to join the conversation.

More
6 years 6 days ago #56945 by Mazi

ckwill90 wrote: If I notice some type of pattern I will post back.

That would be great. We need some hint to start with, maybe others can help as well because this issue shows up regularly!?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form