Problems with the translation page layout

More
1 month 6 days ago #186682 by davebostockgmail
Version 3.17.7+190627

When I go into the quick translation page to overlay the survey with another language everything seems ok ... as per image 1 .... however when I go to the question page the other language box is small and pushed off the page.

I think this is due to the length of the question text .. this is because I use quite a lot of scripts in the questions and in one case to create a lookup question ...this needs to be in there but it means that the translation page layout is totally useless. Image 2

Is there any setting in the CSS or template file I can use to address this?

Thanks in advance as always
Dave
Attachments:

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
1 month 6 days ago #186714 by DenisChenu
Maybe there are an issue in LimeSurvey

1. «I use quite a lot of scripts» : in my opinion question text must be filtered in quick translation
2. to the length of the question text : even we specific part etc … this muts not happen …

Please : www.limesurvey.org/community/bug-tracker

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
1 month 6 days ago #186716 by davebostockgmail
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
1 month 6 days ago #186722 by davebostockgmail
LSS uploaded to the bug tracker as requested Denis
Thanks
Dave

Please Log in or Create an account to join the conversation.

More
1 month 6 days ago #186724 by DenisChenu
Yep :) Thanks , more quick to understand and fix with a sample ;).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
1 month 5 days ago #186744 by davebostockgmail
I have found out what the issue is with this ... it is that the screen is controlled by the length of the question text.

I had an equation question in there with a lot of conditions ...
Q2=If(Q1_A=="Y",1,if(Q1_B=="Y",2 ....... if(Q1_Z=="Y",26}}}}}}}}}} etc.

This seems to have been interpreted as one word and there was no split to adjust the screen size in term of columns... adding in a newline in the source code has corrected the issue.

To my mind this is still a bug as the original text should have a limit to allow the translation target box to be shown.

I will leave it on the bug tracker and update with this.
The following user(s) said Thank You: tpartner

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!