Question index issues

More
8 months 1 week ago #180076 by marmo91
Hello everyone, I created a survey with the following features:

-Questions index setted on FULL
-Groups of questions visible based on user attributes
-Displaying questions for groups



When a user accesses the survey, initially displays all groups in the index, advancing in the compilation, the index is filtered showing only the groups of questions accessible to the user.

How can I view only the correct groups in the index from the beginning?

Thank you all

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
8 months 1 week ago #180077 by DenisChenu
Replied by DenisChenu on topic Question index issues
Maybe (unsure)

Add a group at 1st position with only an hidden question.

The index part is tested after survey creation at the same time displaying 1st group. Then maybe ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #180090 by marmo91
Replied by marmo91 on topic Question index issues
Hi, I've executed your instructions, but the problem persists.

Would it be possible to retrieve the list of groups visible to the current user through some javascript function? and then hide the elements with a script added in the theme?

Thank you

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!