Syntax error when launching with a Token table

More
6 days 22 hours ago #168897 by RaphPro
RaphPro created the topic: Syntax error when launching with a Token table
Good morning everyone!

I'm brand new on this forum, but a user of LimeSurvey for several months.
I really appreciate what this great tool can do!

Recently, some colleagues of mine and myself experienced an issue with the Token table.
Let's recap:
1. We build the survey and test it: fine;
2. We initiate a list of participants: fine;
3. We import the list of participants (.csv), no error: fine;
4. We generate tokens: fine;
5. When we try to launch the survey with any of the tokens, we experience the same issue, as described below.

Error message is:
"CDbCommand failed to execute the SQL statement: SQLSTATE[42601]: Syntax error: 7 ERROR: zero-length delimited identifier at or near """"
LINE 2: ("startlanguage", "", "", "", "", "", "", "", "")"
No matter if we try to launch the survey from the token table or via the invitations sent by email.

Version is 2.73.1 (sorry, I know this is an old version but I cannot update it myself).

I tried to Google the issue and to delete and re-create the token table, but the same message appears. It seems not to be survey-specific as we have the issue on several surveys.
I compared the .csv files generated by failing and working surveys but I could not detect any differences that could explain the error.

I am sorry, this may be for a very simple reason, but for now I cannot figure out why on my side...

Any idea is welcome, thanks a lot in advance!

Best regards,

Please Log in or Create an account to join the conversation.

More
6 days 18 hours ago #168905 by Joffm
Joffm replied the topic: Syntax error when launching with a Token table
Hi,
the best is to provide a sample survey (*.lss) and a dummy csv participants file that show the error on your side.

Maybe somebody can reproduce and see where there is an issue.

And IMO not all fields behind "language" should be empty.
These are "validfrom,validuntil,invited,reminded,remindercount,completed,usesleft"
"invited", "reminded" and "completed" should be "Y" or "N"
"remindercount" and "usesleft"some numeric value.


Best regards
Joffm
The following user(s) said Thank You: RaphPro

Please Log in or Create an account to join the conversation.

More
6 days 14 hours ago #168923 by RaphPro
RaphPro replied the topic: Syntax error when launching with a Token table
Hi Joffm,

Thanks a lot for your reply!

I checked, the following fields are correctly filled-in. When I open the window to modify the participant, I cannot see any error.
"validfrom,validuntil" are empty, but even filling then in does not improve the situation...

Anyhow, I will try to generate a dummy file on Monday for you to test.

Thanks again!

Best regards,

RaphPro

Please Log in or Create an account to join the conversation.

More
3 days 15 hours ago #168989 by RaphPro
RaphPro replied the topic: Syntax error when launching with a Token table
Hi again,

I then tried to create a dummy survey, to reproduce the error.
I think the issue is really with the token table, not the survey, as I could reproduce the error on different surveys with the same table.
I suppose this is due to the .csv file I try to import.
I attach here below the result from the CSV file generated by LimeSurvey after the import; I have no error after the import.

Thanks in advance for your help!

Best regards,

Raphaël
Attachments:

Please Log in or Create an account to join the conversation.

More
3 days 13 hours ago #168995 by holch
holch replied the topic: Syntax error when launching with a Token table
Your CSV file imported without any errors into my Version 3.7.3+180516, as well as into my Version 2.73.1+171220.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
2 days 22 hours ago #169014 by RaphPro
RaphPro replied the topic: Syntax error when launching with a Token table
Hi holch,

Thanks for having tried!
Same here, no errors when importing.
But then I go to the participant table, click on the little gear in front of any participant, I get the error. Same happens through the link sent in the invitation to the survey.

So I really struggle to understand what triggers this failure...

Thanks in advance for your help,

Best regards,

Please Log in or Create an account to join the conversation.

More
2 days 17 hours ago #169032 by holch
holch replied the topic: Syntax error when launching with a Token table
Clicked on the little gear in front of a participant in Version 2.73.1+171220 and I get this:

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Attachments:

Please Log in or Create an account to join the conversation.

More
2 days 17 hours ago #169033 by RaphPro
RaphPro replied the topic: Syntax error when launching with a Token table
Hi holch,

Thanks for testing.
I have the same Version 2.73.1+171220, but I still get the error...
That's quite weird.

Thanks in advance,

Best regards,

Please Log in or Create an account to join the conversation.

More
2 days 17 hours ago #169035 by holch
holch replied the topic: Syntax error when launching with a Token table
I would assume that there is something wrong with your installation or server configuration.

It might still have something to do with your survey. My test survey is basically an empty survey, with nothing in it.

So here a few things you can do:
Post some details about your server configuration here. In 3.x you would just need to click on the version in the lower right corner and receive details about your configuration. In 2.7x this feature doesn't exist yet, so you will get these details manually.
Post an example survey file (not sure if .lss files include token tables or if you would need to export as .lsa file) for which this error occurs to you.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
1 day 22 hours ago #169067 by RaphPro
RaphPro replied the topic: Syntax error when launching with a Token table
Hi holch & guys,

Thanks for your support!
The administrator of the LimeSurvey setup realized that one old defective component was triggering the error, hence the issue being seen in different surveys.
Anyhow, I will from now make sure all my .csv have all mandatory fields filled-in, so that I am not introducing any error in the participant list.

Thanks to all of you!

Best regards,

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!