Are bootstrap themes compatible in Version 3?

More
7 months 1 week ago #162245 by bruce78
bruce78 created the topic: Are bootstrap themes compatible in Version 3?
Reading the manual it seems that Bootstrap themes can be used in the new template engine.

Bootstrap theme: here, you can choose a Bootstrap theme to load. They come from Bootswatch bootswatch.com/3/


Am I right to assume that LS now lets you upload a bootstrap theme in order to create a new survey theme?

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #162262 by LouisGac
LouisGac replied the topic: Are bootstrap themes compatible in Version 3?
it was already the case in 2.x
btw: I'd like to add a CDN option for bootswatch themes (knowing that fonts in those themes are already using CDN, not local server)

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #162269 by LouisGac
LouisGac replied the topic: Are bootstrap themes compatible in Version 3?
also, for people interested to know how to create a theme from a custom bootstrap theme called custom.css:

just extends vanilla, or any other template, and in the XML file replace:
github.com/LimeSurvey/LimeSurvey/blob/ma...a/config.xml#L64-L66
        <!-- If empty, bootstrap css/js files will not be loaded. In the future, we may have more engines, like foundation -->
        <cssframework>
            <name>bootstrap</name>
        </cssframework>


by something like:
github.com/LimeSurvey/LimeSurvey/blob/ma...h/config.xml#L61-L64
        <!-- If empty, bootstrap css/js files will not be loaded. In the future, we may have more engines, like foundation -->
        <cssframework>
            <name>bootstrap</name>
            <css replace="css/bootstrap.css">css/variations/mycustom.css</css>
        </cssframework>


Then to create a list of custom themes that your users can choose inside of the template options, you can have a look to what we did for bootswatch/fruity options.

You should alsto try to create your own option page looks and feels.

More infos about the new template engine here:
manual.limesurvey.org/New_Template_System_in_LS3.x

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #162270 by bruce78
bruce78 replied the topic: Are bootstrap themes compatible in Version 3?
Thank you for the update...

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!