Check out the LimeSurvey source code on GitHub!

Unnecessary Span in the end message box

More
3 years 2 weeks ago - 3 years 2 weeks ago #103032 by mrli999
I hope to display the score I got using EM in the end message. And it did apprear,just like the following 1.8. However there also apprear a unneceesary span,just ilike: <span id='LEMtailor_Q_0_11'>1.8</span>

I don't want that span. How can I delete it?

Original code:
<p> <img alt="" src=" www.abcdefg.com/result/examples/new3.php...;d=5&e=3&f=6 " style="width: 700px; height: 230px;" /></p>

However the output

<p> <img alt="" src=" www.abcdefg.com/result/examples/new3.php?a= <span id='LEMtailor_Q_0_11'>1.8</span>&b=2&c=3&d=5&e=3&f=6" style="width: 700px; height: 230px;" /></p>
Last Edit: 3 years 2 weeks ago by mrli999.

Please Log in to join the conversation.

More
3 years 2 weeks ago #103039 by mrli999
I got five scores through EM, and I would like pass those five scores to another php page. what should I do in the end message box?

Please Log in to join the conversation.

More
3 years 2 weeks ago #103042 by DenisChenu
What is your LimeSurvey version and build number ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: mrli999

Please Log in to join the conversation.

More
3 years 2 weeks ago #103050 by mrli999

DenisChenu wrote: What is your LimeSurvey version and build number ?


2.05,131219

Please Log in to join the conversation.

More
3 years 2 weeks ago #103074 by tpartner
Hmm...I can't reproduce that problem.

Here is a small survey that pipes the value of an equation question into the src attribute of an image in the end message. Can you test with this sample?

File Attachment:

File Name: limesurvey...8692.lss
File Size:13 KB

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Attachments:
The following user(s) said Thank You: mrli999

Please Log in to join the conversation.

More
3 years 1 week ago #103079 by mrli999

tpartner wrote: Hmm...I can't reproduce that problem.

Here is a small survey that pipes the value of an equation question into the src attribute of an image in the end message. Can you test with this sample?

File Attachment:

File Name: limesurvey...8692.lss
File Size:13 KB


Dear Tpartner,

Thank you very much for your help. some additional information:
1. I use all in one model.

2.I calculate 6 scores through EM.

3.It seems the same problem as: bugs.limesurvey.org/view.php?id=8323 . Sometimes ok, sometimes apprear.

Please Log in to join the conversation.

More
3 years 1 week ago - 3 years 1 week ago #103100 by tpartner
Oh, now I see - the problem only appears in "all-in-one" mode.

I'm not sure it's related to bug 8323 so I opened a new one - bugs.limesurvey.org/view.php?id=8509 . Please add to the bug as you see fit.

.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 3 years 1 week ago by tpartner.
The following user(s) said Thank You: DenisChenu, mrli999

Please Log in to join the conversation.

More
3 years 1 week ago #103290 by tpartner
This will be fixed in the next 2.05 release (tomorrow?).

bugs.limesurvey.org/view.php?id=8509

.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form