Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Array Question Type Issue

Array Question Type Issue 3 years 5 days ago #102155

  • fenjiao
  • fenjiao's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hi All,

I am having an issue with array type question.
I have created a simple survey using Lime Survey 2.00+ Build 131122 with only 4 simple questions. 3 of the questions are rating about a hotel in different area, which the guest need to choose from this answer list: 'Wonderful, Good, So so... and also Awful'.
Example Question Type: Array
Question:- How you rate your stay at our hotel?
Answer:- Wonderful, Good, So so..., Awful
After I setting up all these, I had clicked on 'Check Survey Logic for this question' button, it came out with a table (refer attachment). Under Relevance section, the [Value] all showed as 0, how can I solve it?

Attached with all the related screenshots.

Thanks in advance!
Attachments:
The administrator has disabled public write access.

Array Question Type Issue 3 years 5 days ago #102162

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6571
  • Thank you received: 1477
  • Karma: 579
Do you get the correct presentation and data?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Array Question Type Issue 2 years 11 months ago #102606

  • fenjiao
  • fenjiao's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
I also not sure whether is correct. Can you help me to check? I can give you the access.
The administrator has disabled public write access.

Array Question Type Issue 2 years 11 months ago #102610

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6571
  • Thank you received: 1477
  • Karma: 579
I don't think I need access. Just activate the survey and test it to make sure that your data is being recorded as expected. I suspect this is simply a problem with the display of the Survey Logic File and does not affect the data.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.
Time to create page: 0.196 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form