Lime not sending out notifications

More
4 years 1 month ago #99307 by alecabral
alecabral created the topic: Lime not sending out notifications
Hi guys!
I am new to LimeSurvey. Just got it installed on my server and I already have my first survey going on. The one thing I haven't been able to figure out is the notification thing: I need to get notifications each time someone completes the survey. I'm using gmail as my email service, so I completed the global email notification area with gmail info.

Current SMTP: smtp.gmail.com:25 with SSL, SMTP debug off. The rest of the info is there (user and pass), but I don't think it's even sending emails.

I also accessed the email templates part of the survey, and this is what I see (see image attached).



I noticed the "Detailed admin notification email" appears blank. i figured that's the problem but I don't know.

Can you please confirm what's wrong? what can I do to fix it?

Thanks!
Attachments:

Please Log in to join the conversation.

More
4 years 1 month ago #99406 by tpartner
tpartner replied the topic: Lime not sending out notifications
On most servers you can use the default PHP Mailer instead of SMTP:



You will need to place your email address in one of the notification email fields:

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Attachments:

Please Log in to join the conversation.

More
4 years 1 month ago #99410 by alecabral
alecabral replied the topic: Lime not sending out notifications
Hi Tony,
Thanks for your reply! I had tried that already but it didn't work. I reverted back to it just in case so I could try once more but it did nothing. mailer is back to PHP (default), I just completed the survey again but no notifications came out.

Is there anything on the server I should be checking for that php mailer to work?

Thanks,
Alejandro

Please Log in to join the conversation.

More
4 years 1 month ago #99478 by tpartner
tpartner replied the topic: Lime not sending out notifications
Unfortunately, I'm not a server expert. Perhaps someone with more knowledge in that area could answer.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 1 month ago #99488 by jelo
jelo replied the topic: Lime not sending out notifications
What did you get as error message when activating the debug mode?

Make sure that you use the correct email address of your gmail account as Admin E-Mail.

Try to use "smtp.gmail.com:465" with SSL .

Make sure that the complete username is used for the smtp server: This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in to join the conversation.

More
4 years 1 month ago #99515 by DenisChenu
DenisChenu replied the topic: Lime not sending out notifications
Hi,

Did you have access to server log ? Can you set "emailsmtpdebug" to 1 in your application/config/config.php file.
'config'=>array(
		'debug'=>2,
                 'emailsmtpdebug'=>1
		'debugsql'=>0 // Set this to 1 to enanble sql logging, only active when debug = 2
	)


Denis

PS:

tpartner wrote: Unfortunately, I'm not a server expert. Perhaps someone with more knowledge in that area could answer.

Hi Tony, it same think like other : get the log/debug ;).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now