migration LS v1.87 to LS V2.0

More
4 years 5 months ago - 4 years 5 months ago #90239 by asklepio
asklepio created the topic: migration LS v1.87 to LS V2.0
Hi,

Our actual poll tool is under LS v1.87, we are setting up the new version with LS v2.0.
Of course, we want to be able to access the v1.87data in the new tool.

My first question is : is it possible since the table structures are not the same anymore.

What are the steps to follow to succeed this migration, for instance:

1. go online with the LS2.0.
close the new poll creation on LS1. but still allow the answers

2. shut down LS1.87 once the poll is closed.
3. migrate the data LS1.87 data to LS2.0 table (is this easy?)

Perhaps it's better to just keep the old data accessible via a different page to the new page?

thanks for your advice
Last Edit: 4 years 5 months ago by asklepio.

Please Log in to join the conversation.

More
4 years 5 months ago #90281 by DenisChenu
DenisChenu replied the topic: migration LS v1.87 to LS V2.0
Hello,

Seems there are some problem from updating from 1.87 to 2.0 but : LS have to update the table automaticlly.

Allways do a complete backup before updating.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now