Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Problem with {TOKEN} values

Problem with {TOKEN} values 3 years 9 months ago #89043

  • Loco
  • Loco's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Hi,

I have a weird probleme here.

Using latest release (Version 2.00+ Build 121121) with closed survey and multiple token uses.

So here is what happens:

In invitation and reminder email passing {FIRSTNAME}, {LASTNAME} and {USESLEFT} values works perfectly (bit it won't pass value of {TOKEN:FIRSTNAME}, {TOKEN:LASTNAME}, {TOKEN:USESLEFT).

But in basic admin notification, advanced admin notification and confirmation emails values are only passed if I use {TOKEN:FIRSTNAME} and {TOKEN:LASTNAME}. Value {TOKEN:USESLEFT} doesn't work at all, neither does {USESLEFT} (big problem for me).

Also, passing values of {TOKEN:FIRSTNAME} and {TOKEN:LASTNAME} in question group description work normally, but I cannot get {TOKNEN:USESLEFT}, nor {USESLEFT} values. even bigger problem for me.


So, my question is, is this a bug or I'm just very dumb and missing something.
Thanks
The administrator has disabled public write access.

Problem with {TOKEN} values 3 years 9 months ago #89047

  • Loco
  • Loco's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
is there any way arround this? maybe some javascript reading token table and USESLEFT value directly, bypassing Expression Manager or something?
The administrator has disabled public write access.

Problem with {TOKEN} values 3 years 8 months ago #89100

  • tomscher
  • tomscher's Avatar
  • Offline
  • Junior Lime
  • Posts: 34
  • Thank you received: 7
  • Karma: 2
Does the bug occur if you are using the INSERTANS function?
The administrator has disabled public write access.

Problem with {TOKEN} values 3 years 8 months ago #89107

  • Loco
  • Loco's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
INSERTANS works fine.

Also, I have noticed that when I open suvey in limesurvey administration sometimes TOKEN:ATTRIBUTE_CPDB_1 is marked as undefined variable (red rectangle and letters) although it works fine in survey, and TOKEN:USESLEFT is marked with normal brown letters (but never works in survey - marked as undefined variable).

sometimes it is other way arround with this two variables.

TOKEN:FIRSTNAME and TOKEN:LASTNAME are always marked properly and work fine.
Last Edit: 3 years 8 months ago by Loco.
The administrator has disabled public write access.

Problem with {TOKEN} values 3 years 8 months ago #89119

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
Loco wrote:
but I cannot get {TOKNEN:USESLEFT}, nor {USESLEFT} values
This work in 1.92, please fill a bug report.

(with a lss file and a csv tokens file).

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Problem with {TOKEN} values 3 years 8 months ago #89122

  • Loco
  • Loco's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Thanks
The administrator has disabled public write access.

Problem with {TOKEN} values 3 years 8 months ago #89128

  • Loco
  • Loco's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
DenisChenu wrote:
This work in 1.92

I can confirm that it works perfectly in 1.92. Just tried it. Thanks again.
The administrator has disabled public write access.

Problem with {TOKEN} values 3 years 8 months ago #89136

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
Loco wrote:
DenisChenu wrote:
This work in 1.92

I can confirm that it works perfectly in 1.92.
DenisChenu wrote:
please fill a bug report.
And leave the link of the bug report here (with the number).

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Problem with {TOKEN} values 3 years 8 months ago #89206

  • Loco
  • Loco's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
DenisChenu wrote:
And leave the link of the bug report here (with the number)

bugs.limesurvey.org/view.php?id=6966
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.232 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form