Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Language switcher not showing up on welcome page

Language switcher not showing up on welcome page 3 years 9 months ago #88091

  • lolo
  • lolo's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Hi all,

Something strange is going on here (LS2.0): I have created a survey in two languages (fr+de) including a welcome page.

Upon taking the survey (it's an open survey), the language switcher appears on the questions page but not on the welcome page.

I checked my welcome.pstpl and the "{LANGUAGECHANGER}" tag is present.

To make sure I was looking at the right template file I added dummy characters around the tag (so it was "xx{LANGUAGECHANGER}yy" in my template). On reloading the string "xxyy" shows up so I am definitely looking at the right place.

Looking at the HTML source of the welcome page, there is nothing between my "xx" and "yy" markers.
So, somehow, it seems the tag is not populated at all by LS.

Any idea?

PS: congrats to the dev team for taking 2.0 out.
Last Edit: 3 years 9 months ago by lolo.
The administrator has disabled public write access.

Language switcher not showing up on welcome page 3 years 9 months ago #88162

  • lolo
  • lolo's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
No idea ?

Should I rather post that to the "Design issues" forum ?

Regards,
The administrator has disabled public write access.

Language switcher not showing up on welcome page 3 years 9 months ago #88172

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9305
  • Thank you received: 1330
  • Karma: 386
Think you have to put this in bug report.

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Language switcher not showing up on welcome page 3 years 9 months ago #88408

  • lolo
  • lolo's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Thanks,

Issue 6877 created.
The administrator has disabled public write access.

Language switcher not showing up on welcome page 3 years 9 months ago #88416

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9305
  • Thank you received: 1330
  • Karma: 386
lolo wrote:
Thanks,

Issue 6877 created.
To late ;)

github.com/LimeSurvey/LimeSurvey/commit/...01d03f1d13d31ed7dff7

Maybe some change for 2.1, but it's OK for next release ;)
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.350 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form