Forward answer in end url

More
5 years 1 week ago - 5 years 1 week ago #87888 by eblanche
eblanche created the topic: Forward answer in end url
Hi all,
I am trying to forward an answer from a survey to another url using the end url feature.
I fill the end url field as follow:
http://another.url/index.php?MYVAR={QCODE}
where QCODE corresponds to the question code in the survey.
I even tried with the SGQA code with {INSERTANS:12245X1X1} but in both cases I get a red box error message mentioning "unknown variable".

Using Version 2.00+ Build 121106

What am I doing wrong ?
Is there any setting somewhere to activate the resolution of those variables for the end url ?
Last Edit: 5 years 1 week ago by eblanche. Reason: Enclosed url with code tag

Please Log in to join the conversation.

More
5 years 1 week ago #87892 by DenisChenu
DenisChenu replied the topic: Forward answer in end url
With a activated survey ? And when you get the survey ?

If yes , and if you are in the last LS version, please fill a bug report :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
5 years 1 week ago #87901 by eblanche
eblanche replied the topic: Forward answer in end url
Thanks Denis for your answer.
The survey was not active but turning it into active does not change the behavior.
I'll then fill in a bug report.

Thanks
Eric

Please Log in to join the conversation.

More
5 years 1 week ago #88045 by jelo
jelo replied the topic: Aw: Re: Forward answer in end url
Seemed to be fixed. Not tested be myself.
github.com/LimeSurvey/LimeSurvey/commit/...27dc2b8fa9a5d6e04645

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!