Check out the LimeSurvey source code on GitHub!

Can I do quota management on Tokens fields?

More
4 years 3 months ago #87703 by amoswagon
Can I do quota management on Tokens fields?
I want to pre-load Gender info (Male/ Female) into the tokens list.
Can I activate the quota management based on who showed up? for example I want only 50 female?

I know I can set 'show' conditions based on Tokens fields, but I couldn't find a way to limit quotas using them.

Thanks!

Please Log in to join the conversation.

More
4 years 3 months ago #87728 by DenisChenu
Hello,

To use quota, you have to put the answer in a "Single choice question" . You can use some javascript to do this.

For example, put M/F in your attribute, Question code : GENDER, SUB QUestion code : M/F, question type: List radio

And in question HTML source (with XSS filtering to no)
<script>
$(function() {
 $("question{QID} input.radio[value='{TOKEN:ATTRIBUTE_1']").click();
});
</script>

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 3 months ago #87737 by amoswagon
This is very helpful but I'm new to it, I need more details with your example.

In Tokens table:
- added attribute called 'male-female' with 'M' and 'F' values (for male and female)

In the Survey:
- added a single choice question (radio list)
- question coded in 'GENDER'
- 2 answer choices: 'M'(code) 'Male' (label), 'F' (code) 'Female' (label)
- added your javascript to the source of the question text
- replaced '{QID}' with 'GENDER'
- replaced 'ATTRIBUTE_1' with 'male-female"

What am I doing wrong?

Thanks!
Amos

Please Log in to join the conversation.

More
4 years 3 months ago #87744 by DenisChenu

amoswagon wrote: - replaced '{QID}' with 'GENDER'
- replaced 'ATTRIBUTE_1' with 'male-female"

What am I doing wrong?

Replacing :)

Limesurvey replace itself {QID} by question number and {TOKEN:ATTRIBUTE_1} by the value of the token attribute.

See : docs.limesurvey.org/tiki-index.php?page=...stion_default_value_

Default value work for text question type, not for single choic question but .val("{TOKEN:ATTRIBUTE_1}") jquery work (for select qestion type, sure).

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 3 months ago #87757 by amoswagon
I get it now. Thank you :blush:
I managed to do it with Text type, but still it doesn't work with single.

<script>
$(function() {
$("question{QID} input.radio[value='{TOKEN:ATTRIBUTE_1']").click();
});
</script>

Do you have a syntax error? I think one '}' is missing after 'ATTRIBUTE_1'.
I'll try to figure it out by myself.

Thanks again.
Amos

Please Log in to join the conversation.

More
4 years 3 months ago #87777 by DenisChenu

amoswagon wrote: Do you have a syntax error? I think one '}' is missing after 'ATTRIBUTE_1'.
I'll try to figure it out by myself.

You're right, and lost some # too.
$(function() {
 $("#question{QID} input.radio[value='{TOKEN:ATTRIBUTE_1}']").click();
});

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 3 months ago #87807 by amoswagon
It's working! Could you believe?! :ohmy:
Thank you!
Amos

Please Log in to join the conversation.

More
4 years 3 months ago #87838 by DenisChenu

amoswagon wrote: It's working! Could you believe?! :ohmy:

Yes :P but if you don't have token table and token attribute_1,JavaScript is breaked.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 2 months ago #89907 by amoswagon
Hi.

Since I upgraded to 2.00+ the javascript you gave me does not work!?
Very frustrating!

Any ideas?

Amos

Please Log in to join the conversation.

More
4 years 2 months ago #89918 by tpartner
Have you upgraded to the latest version? There was a problem with {QID} in 2.0 but it has been fixed recently.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form