Display a message and end survey based on answer

More
4 years 9 months ago - 4 years 9 months ago #82237 by efici_km
Hi all,
I am trying to find out how to do something that I think is very simple, but I haven't found the answer yet.

I have some Yes/No questions and I want to display a message and end the survey if the answer is No. There are several ways this could be accomplished:

1. Display a message right below the question when "No" is chosen that says "Thank You, the survey is complete" and ends the survey.

2. Pop-up a message that says "Thank You, the survey is complete" and ends the survey.

3. Set two different ending texts, one for people who finish the survey with "Yes" answers and different text for those who end the survey early by answering "No".

Can you help me with the best way to accomplish one of these?
Last Edit: 4 years 9 months ago by efici_km.

Please Log in to join the conversation.

More
4 years 9 months ago #82254 by Mazi
You can use quotas to terminate the survey and show a predefined warning message. Use a limit of 0 for the "no" answer option.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago - 4 years 9 months ago #82261 by efici_km
Thank you I am trying this now.

I think I might be able to get this to work by defining only the questions/answers I want to set quota of "0" on. Thanks again for your assistance.
Last Edit: 4 years 9 months ago by efici_km. Reason: clarification

Please Log in to join the conversation.

More
4 years 9 months ago #82285 by Mazi

efici_km wrote: Thank you I am trying this now.

I think I might be able to get this to work by defining only the questions/answers I want to set quota of "0" on. Thanks again for your assistance.

You're welcome :-)

If our hints have been helpful and you enjoy limesurvey please consider a donation to give Limesurvey a future .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago - 4 years 9 months ago #82286 by efici_km
Yes, you have been helpful and I would like to contribute.

I have set up quotas (with terminate survey with warning) and added the answer "No" on a Yes/No question. I set the quota to 0. When I test the survey and select "No" for that question, nothing happens and the warning message is not displayed. Although under quotas it shows "Active", I am wondering if I have to enable it somewhere else too? I read all about quotas but do not see that there is any other global setting that would affect quotas. Any hint is appreciated.
Last Edit: 4 years 9 months ago by efici_km.

Please Log in to join the conversation.

More
4 years 9 months ago - 4 years 9 months ago #82289 by efici_km
I think the problem was having multiple questions on one quota entry. Even though LS allows me to choose answers from multiple questions, it would not work until I made separate quota entries for each answer I wanted to apply the quota to. Working now.
Thanks, great product and community.
Last Edit: 4 years 9 months ago by efici_km. Reason: followup edit

Please Log in to join the conversation.

More
4 years 9 months ago #82318 by Mazi
quotas only work if the survey is activated. Did you activate your survey?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago - 4 years 9 months ago #82329 by efici_km
Yes it was active. I got it working after removing some conditions and then only putting one question under each quota entry. I will now add the simple conditions back and see if the quotas still work.
Thank you!
Last Edit: 4 years 9 months ago by efici_km.

Please Log in to join the conversation.

More
4 years 9 months ago #82357 by Mazi
If you run into any bugs which you can reproduce, please open a ticket at our Bugtracker.

Thanks!


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.