Check out the LimeSurvey source code on GitHub!

Need help with prefilling questions

More
4 years 9 months ago - 4 years 9 months ago #80011 by Raisis
Hi everybody,

I like to prefill two answers of my survey. It's a personal survey where I know my audience and I would like to prefill there name (it's a text input field)

So I've got a suvrey with the ID 999, the group ID is 1, questions ID is 1 question code is name.

I thought this link would prefill the question:

http://survey-link/index.php?sid=999&999X1X1name=MyName

But it does not work :(

Can you help me finding the mistake? Thank you :)
Last Edit: 4 years 9 months ago by Raisis.

Please Log in to join the conversation.

More
4 years 9 months ago #80018 by tpartner
If it is a short-texr question, try:
survey-link/index.php?sid=999&999X1X1=MyName

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 9 months ago #80026 by Raisis
I've tried it. And the field is still empty :(

Please Log in to join the conversation.

More
4 years 9 months ago #80030 by DenisChenu
try to add &newtest=Y to the url.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 9 months ago #80085 by Mazi
1. Which Limesurvey version do you use?

2. Did you set the question to be always hidden? If so and you change that setting, does it work fine?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form