Check out the LimeSurvey source code on GitHub!

How can audio files be attached?

More
5 years 1 month ago #72824 by musicpsy
Hi all,
I would like to put some audio data in the survey, and I am interested in
how participants response to the sounds.
How can I upload audio data in the survey? Thank you for your help in advance!
best,
musicpsy

Please Log in to join the conversation.

More
5 years 1 month ago #72827 by tpartner
Have a look at this workaround. It's kinda old but should still work.

docs.limesurvey.org/Workarounds%3A+Quest...g_audio_in_questions

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
5 years 1 month ago #72829 by musicpsy
thank you for your prompt reply!
I just read the link, but where can I see the code?
I did not find a button to open the code in the LimeService.

Please Log in to join the conversation.

More
5 years 1 month ago #72830 by tpartner
Click Full Screen:




And then Source:


Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Attachments:

Please Log in to join the conversation.

More
5 years 1 month ago #72831 by musicpsy
many thanks! I will try!

Please Log in to join the conversation.

More
5 years 1 month ago #72832 by musicpsy
I pasted the code, and I would like to chang the "template folder". But it only refers to "an absolute URL in the src parameter"(so it seems the path like "C:\\temp\\a.wav" does not work). What does this mean? should I save the audio data somewhere in the Internet? How should I do?

Please Log in to join the conversation.

More
5 years 1 month ago #72840 by Mazi
Usually those files should be stored on the server. Can you explain the problem in more detail?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 1 month ago #72948 by musicpsy
ok, for instance, I would like to put a WAV file in a survey, and ask participants to make judgment(whether they like it or not).
Then according to the link (see above), I copied the code
"<embed height="20" width="128" autostart="false" controls="console"
loop="true" volume="50" src="{TEMPLATEURL}audio_1.mp3"></embed>"
in the LimeService Question source.
In the link page it says "template folder" refers to "an absolute URL in the src parameter".
Then how can I stored a file in a server? Where can I find a server? Sorry, I have no such experience.

Please Log in to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #72952 by tpartner
You can upload the file as a survey resource.

1) Place the file in a zipped archive.

2) Go to Survey properties --> General setting --> Resources, browse to your zipped folder and upload it.


3) The path to the file will then be:
upload/surveys/yourSurveyID/yourFile.wav

4) so the embed code would look something like:
<embed height="20" width="128" autostart="false" controls="console"
loop="true" volume="50" src="upload/surveys/12345/audio_1.mp3"></embed>

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Attachments:
Last Edit: 5 years 1 month ago by tpartner.

Please Log in to join the conversation.

More
5 years 1 month ago #72953 by musicpsy
Thanks!
I just followed the steps, but at the end, the player did not appear, but the words in the code appeared in the preview.

Please Log in to join the conversation.

More
5 years 1 month ago #72955 by tpartner

...but the words in the code appeared in the preview. ...

Did you disable the XSS filter and place the code in the source of the question?

docs.limesurvey.org/tiki-index.php?page=..._etc._in_LimeSurvey_

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
5 years 1 month ago #72979 by musicpsy
Thank you for your reminding! I just turned it off.
Then I tried three kinds of audio files: wav, wma, mp3 (the file should not be larger than 2M), the results were:
- the player appeared only with wma file in the preview, but I don't know why no sound came out when I pressed the play button.
- there was no player with wav and mp3 files, but a scroll bar in the preview.

Please Log in to join the conversation.

More
5 years 1 month ago #72993 by Mazi
These problems can also be connected to missing browser plugins.

Do you have a test link for us?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 1 month ago #73027 by musicpsy
sorry, at the moment I don't have a test link, I just start with the LimeService.
I tried google chrome and explore, they have the same problem.

Please Log in to join the conversation.

More
5 years 1 month ago #73033 by Mazi
At global settings -> security you can disable admin only preview and then send us the link to the survey so we can have a look.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form