Check out the LimeSurvey source code on GitHub!

Array Filter data was not captured

More
5 years 4 months ago #67296 by sivajik
Currently I have an one survey with Array Filter option, When I take the survey, the programming seems to work fine...but for some reason the data was not captured for that question (I just look at responses and it says that all responses are "non completed or not displayed", even though anyone who chose any choice except Never received this question). Do I need to change anything in the settings to see the data in response? Please do the needful.

For example I have created one test survey with array filter option.

survey.rodale.com/admin/admin.php?sid=38732#

Please Log in to join the conversation.

More
5 years 4 months ago #67297 by holch
The link doesn't work.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 4 months ago #67308 by Mazi
1. The survey seems to be broken, I see no answer options at survey.rodale.com/index.php?sid=38732#

2. Which Limesurvey version do you use?

3. Can you attach the survey here for testing?

4. Did you modify the template?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 4 months ago #67326 by sivajik
I am sorry, here's the attachment of my test survey.

I am using Version 1.87+ (8406)

No I didn't modify anything in the template.

File Attachment:

File Name: limesurvey...8732.csv
File Size:5 KB
Attachments:

Please Log in to join the conversation.

More
5 years 4 months ago #67328 by Mazi
I can reproduce the problem at the latest build. I get a warning at testing:
Notice: Undefined index: 38732X26X399 in C:\xampp\htdocs\limeSOURCE\limesurvey_current\common_functions.php on line 4661

Your survey somehow looks broken to me. Please try to rebuild those two questions and let me know if the error still shows up.

Attached is a test survey which supports different array filter settings:

File Attachment:

File Name: Limesurvey...sion.lss
File Size:46 KB


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
Attachments:

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form