Check out the LimeSurvey source code on GitHub!

{SURVEYURL} to be openened in our website (wrapper)

More
5 years 8 months ago #62465 by SPABO
In the e-mail templates I can use {SURVEYURL} to go directly to the survey.

However, I wish to have the survey openend in a wrapper in our website

The link to the wrapper : www.ourwebsite.nl/survey.html

Any ideas??

Please Log in to join the conversation.

More
5 years 8 months ago #62470 by tpartner
You will need to hard code the URL instead of using the {SURVEYURL} placeholder.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
5 years 8 months ago #62474 by SPABO
I thought about that...
But how to get the token in the URL

Please Log in to join the conversation.

More
5 years 8 months ago #62484 by tpartner
Can you use the {TOKEN} placeholder in the hard coded URL?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
5 years 8 months ago #62486 by SPABO
I tried this in the wrapper:
www.ourwebsite.nl/survey/index.php?lang=...mal&sid=22222&{TOKEN }

This does not work

As said , in the email I'm using www.ourwebsite.nl/survey.html to open the wrapper

Please Log in to join the conversation.

More
5 years 8 months ago #62487 by tpartner

As said , in the email I'm using www.ourwebsite.nl/survey.html to open the wrapper

Does this mean that you are running the survey in an iframe?

If so, I think you'll need to change that page to .php and then use a script to grab the token from the URL and append it to the src attribute of the iframe.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
5 years 8 months ago #62492 by SPABO
Hi Tony

It's a JOOMLA application and not sure where/how etc

I cannot imagine I was the only one with this "problem"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form