Check out the LimeSurvey source code on GitHub!

Export to DOC - problem with encoding, assessment

More
5 years 8 months ago - 5 years 8 months ago #61988 by petrahele
Hi,
I wanted to export the data from my survey, but after opening the DOC file in OpenOffice.org Writer I get incorrectly displayed national characters. I do not know whether I have bad encoding set in Limesurvey or where is the problem. I know that my native language (Czech) uses UTF-8 or CP1250 encoding.
did anybody have similar problem? Any advice appreciated :(

Second, is it possible to include the final score in the text export? I have there all the answers but not the score for whole test and the assessment.

thanks

latest Limesurvey on localhost, Ubuntu 10.04 (lucid), kernel 2.6.32-22-generic, Gnome 2.30.0, hardware: HP 550 laptop, 1GB RAM, Intel Celeron, Intel graphics
Last Edit: 5 years 8 months ago by petrahele.

Please Log in to join the conversation.

More
5 years 8 months ago #61997 by tpartner
Regarding question 2, you could populate a hidden question with the assessment_CURRENT_TOTAL .

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
5 years 8 months ago #62056 by petrahele
Thanks Tony,
however, maybe I am too stupid to understand the structure. My survey has url:
MMSE (Mini Mental State Exam) (ID 42176)
http://localhost/limesurvey/index.php?sid=42176&lang=cs

I read all the links about end url etc. I activated the automatic url loading and then tried:
http://localhost/limesurvey/index.php?sid=42176&lang=cs&{assessment_CURRENT_TOTAL}
and
http://localhost/limesurvey/index.php?sid=42176&lang=cs&var1={assessment_CURRENT_TOTAL}
and also
{assessment_CURRENT_TOTAL}

first two ones redirect me back to the beginning of the survey and third one results in error message (404 Not Found).

could you give me more detailed advice? I think that after one survey with working assessment I will be able to use it in others too. :silly:

thanks

latest Limesurvey on localhost, Ubuntu 10.04 (lucid), kernel 2.6.32-22-generic, Gnome 2.30.0, hardware: HP 550 laptop, 1GB RAM, Intel Celeron, Intel graphics

Please Log in to join the conversation.

More
5 years 8 months ago #62098 by tpartner
1) Does the problem occur in MS Word? Can you attach a sample file?

2) You can use JavaScript and {assessment_CURRENT_TOTAL} to load a hidden question on the last page with the assessment total.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form