Welcome, Guest
Username: Password:
  • Page:
  • 1
  • 2

TOPIC: I can't show question numbers or codes ?

I can't show question numbers or codes ? 5 years 1 week ago #61326

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 4908
  • Thank you received: 720
  • Karma: 220
It is probably not the server that is busy, but your server that doesn't have enough memory for the comfort update. So far I never had problems with the comfort update due to the server being unavailable. But when your memory limit is too small, the update won't work, because the script needs more memory.

What is the exact error message that you receive?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

I can't show question numbers or codes ? 5 years 1 week ago #61327

  • persmash
  • persmash's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Update server busy

The update server is currently busy. This usually happens when the update files for a new version are being prepared.

Please be patient and try again in about 10 minutes.
The administrator has disabled public write access.

I can't show question numbers or codes ? 5 years 1 week ago #61328

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 4908
  • Thank you received: 720
  • Karma: 220
Hmm, OK, this sounds more like a problem with the update server, you are right. Or it might be a connection problem.

Is your server installed locally (within your local network) and for example behind a firewall?

So far I had never problems like this. That is why I am a little surprised.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Last Edit: 5 years 1 week ago by holch.
The administrator has disabled public write access.

I can't show question numbers or codes ? 4 years 2 months ago #77802

  • frisket
  • frisket's Avatar
  • Offline
  • Junior Lime
  • Posts: 26
  • Karma: 0
I am getting the exact same error message:

The update server is currently busy. This usually happens when the update files for a new version are being prepared.

This is while trying to update to 1.92+(120325)

It's been like this all day. Is something really wrong?
The administrator has disabled public write access.

I can't show question numbers or codes ? 1 year 6 months ago #114087

  • zer0mode
  • zer0mode's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
tpartner wrote:
Cool.

For other users - question.pstpl must contain the {QUESTION_NUMBER} and/or {QUESTION_CODE} placeholders.

Hi, this is my question.pstpl, but the question numbers don't appear at all. I'm using the default template on limesurvey hosting service.
<div {QUESTION_ESSENTIALS} class="{QUESTION_CLASS}{QUESTION_MAN_CLASS}{QUESTION_INPUT_ERROR_CLASS}">
    <table class="question-wrapper">
        <tr>
            <td class="questiontext">
                <span class="asterisk">{QUESTION_MANDATORY}</span><span class="qnumcode">{QUESTION_NUMBER} {QUESTION_CODE} </span>{QUESTION_TEXT}<br /><span class="questionhelp">{QUESTION_HELP}</span>
                {QUESTION_MAN_MESSAGE}
                {QUESTION_VALID_MESSAGE}
                {QUESTION_FILE_VALID_MESSAGE}
            </td>
        </tr>
        <tr>
            <td class="answer">
                {ANSWER}
            </td>
        </tr>
        <tr>
            <td class="survey-question-help">
                {QUESTIONHELP}
            </td>
        </tr>
    </table>
</div>

I tried to use Show question number only and Show both in general settings - "Show question number and/or question code"
The administrator has disabled public write access.

I can't show question numbers or codes ? 1 year 6 months ago #114089

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5920
  • Thank you received: 1300
  • Karma: 523
Using those settings and that template, it should work. Can you activate a test survey?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

I can't show question numbers or codes ? 1 year 6 months ago #114100

  • zer0mode
  • zer0mode's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
It works. First I though the reason are the scripts integrated in some of the questions, but in fact I confused the general settings and the survey settings.


This brings another issue. Certain questions in the survey attached are "customised" - they have one or two following questions integrated as columns and therefore their question numbers appear in columns, whereas they shouldn't. Furthermore, all the question numbering down the line messes up because of this.



The simplest solution would be to mark those integrated questions with a help of javascript as "non relevant for question numbering" I suppose. I have no idea how the script would look like.

Another option would be to correct already used script so a question would be copied/transferred in the column of a previous question by leaving out the "th" definition, that is to say the question name. But I think the question itself would be still counted as any other regular question so it's not really a solution.

A sample survey is attached, the scripts used for tailoring are included.


And something else appeared: in certain questions a new line is created right behind the question number.





File Attachment:

File Name: limesurvey...4165.lss
File Size:122 KB


I hope all this makes sense.
Last Edit: 1 year 6 months ago by zer0mode. Reason: few grammar corrections
The administrator has disabled public write access.

I can't show question numbers or codes ? 1 year 6 months ago #114148

  • zer0mode
  • zer0mode's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
Concerning the new line after a question number the problem were whitespace characters which appeared out of nowhere inside the paragraph tags. So instead:
<p>
	My question</p>
should be:
My question

Maybe this has something to do with the option "Hide tip" in the question advanced settings. However, if that happens deleting everything around the question text (including the <p> tags) will help.
The administrator has disabled public write access.

I can't show question numbers or codes ? 1 year 6 months ago #114156

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5920
  • Thank you received: 1300
  • Karma: 523
Can you activate a test survey?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

I can't show question numbers or codes ? 1 year 6 months ago #114158

  • zer0mode
  • zer0mode's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
The link to the test survey. It's similar to the .lss I posted in my last post.
The administrator has disabled public write access.

I can't show question numbers or codes ? 1 year 6 months ago #114161

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5920
  • Thank you received: 1300
  • Karma: 523
After looking at the survey I think that, while you could solve all of the problems with JavaScript, it would be far simpler to manually place he question numbers in the text.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

I can't show question numbers or codes ? 1 year 6 months ago #114165

  • zer0mode
  • zer0mode's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
In fact I started doing that by using {Qcode.qseq} and {Qcode.qseq - n}, where n is a constant used for subtracting.

It's a viable alternative when the survey contains up to 20 or 30 questions. In my case there will be about 70 or 80 questions. A lot of javascript tailoring is used which means all the structure is flexible and I won't really know the exact number of questions just until the survey is launched. If I had to add or remove a question at the beginning that would mean all the qseq codes or the manually set numbers would have to be corrected.

That's why the idea of flagging all the non relevant questions for numbering is not bad. In fact this flag should be accessible in the question advanced setting in one of the next LS versions. Users could then exclude numbering from boilerplate questions and in other situations, like mine for example.
The administrator has disabled public write access.

I can't show question numbers or codes ? 1 year 6 months ago #114207

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5965
  • Thank you received: 364
  • Karma: 259
Coding a sequential numbering when using conditions is nearly impossible. E.g. when having conditions to show/hide questions on the same page this requires updating the question numbers for all questions on that page if an additional question is shown due to conditions.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 1.112 seconds