I can't show question numbers or codes ?

More
6 years 5 months ago #61321 by tpartner
tpartner replied the topic: I can't show question numbers or codes ?
I'm not sure I'm the right guy to help you with updating. I'm more of a client-side (front end) guy that a server expert.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
6 years 5 months ago #61322 by persmash
persmash replied the topic: I can't show question numbers or codes ?
One more question:
I've copied of default template and now I'm working on copy_of_default template. But I can't find its folder on templates folder. Is it same as default?

Please Log in to join the conversation.

More
6 years 5 months ago - 6 years 5 months ago #61323 by persmash
persmash replied the topic: I can't show question numbers or codes ?
I'm sending a screenshot with another problem as I mentioned in first message...
Build number that I use is the latest one. What is this update message about?
Attachments:
Last Edit: 6 years 5 months ago by persmash.

Please Log in to join the conversation.

More
6 years 5 months ago #61324 by tpartner
tpartner replied the topic: I can't show question numbers or codes ?
Your template should be in the /upload/templates directory.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
6 years 5 months ago #61325 by persmash
persmash replied the topic: I can't show question numbers or codes ?
Thank you. I found my template folder. Now how can I fix this "update available error"? And one more thing I can't use ComfortUpdate never. The server is always busy...

Please Log in to join the conversation.

More
6 years 5 months ago #61326 by holch
holch replied the topic: I can't show question numbers or codes ?
It is probably not the server that is busy, but your server that doesn't have enough memory for the comfort update. So far I never had problems with the comfort update due to the server being unavailable. But when your memory limit is too small, the update won't work, because the script needs more memory.

What is the exact error message that you receive?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 5 months ago #61327 by persmash
persmash replied the topic: I can't show question numbers or codes ?
Update server busy

The update server is currently busy. This usually happens when the update files for a new version are being prepared.

Please be patient and try again in about 10 minutes.

Please Log in to join the conversation.

More
6 years 5 months ago - 6 years 5 months ago #61328 by holch
holch replied the topic: I can't show question numbers or codes ?
Hmm, OK, this sounds more like a problem with the update server, you are right. Or it might be a connection problem.

Is your server installed locally (within your local network) and for example behind a firewall?

So far I had never problems like this. That is why I am a little surprised.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Last Edit: 6 years 5 months ago by holch.

Please Log in to join the conversation.

More
5 years 7 months ago #77802 by frisket
frisket replied the topic: I can't show question numbers or codes ?
I am getting the exact same error message:

The update server is currently busy. This usually happens when the update files for a new version are being prepared.

This is while trying to update to 1.92+(120325)

It's been like this all day. Is something really wrong?

Please Log in to join the conversation.

More
3 years 2 weeks ago #114087 by envitera
envitera replied the topic: I can't show question numbers or codes ?

tpartner wrote: Cool.

For other users - question.pstpl must contain the {QUESTION_NUMBER} and/or {QUESTION_CODE} placeholders.


Hi, this is my question.pstpl, but the question numbers don't appear at all. I'm using the default template on limesurvey hosting service.
<div {QUESTION_ESSENTIALS} class="{QUESTION_CLASS}{QUESTION_MAN_CLASS}{QUESTION_INPUT_ERROR_CLASS}">
    <table class="question-wrapper">
        <tr>
            <td class="questiontext">
                <span class="asterisk">{QUESTION_MANDATORY}</span><span class="qnumcode">{QUESTION_NUMBER} {QUESTION_CODE} </span>{QUESTION_TEXT}<br /><span class="questionhelp">{QUESTION_HELP}</span>
                {QUESTION_MAN_MESSAGE}
                {QUESTION_VALID_MESSAGE}
                {QUESTION_FILE_VALID_MESSAGE}
            </td>
        </tr>
        <tr>
            <td class="answer">
                {ANSWER}
            </td>
        </tr>
        <tr>
            <td class="survey-question-help">
                {QUESTIONHELP}
            </td>
        </tr>
    </table>
</div>

I tried to use Show question number only and Show both in general settings - "Show question number and/or question code"

Please Log in to join the conversation.

More
3 years 2 weeks ago #114089 by tpartner
tpartner replied the topic: I can't show question numbers or codes ?
Using those settings and that template, it should work. Can you activate a test survey?

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
3 years 2 weeks ago - 3 years 2 weeks ago #114100 by envitera
envitera replied the topic: I can't show question numbers or codes ?
It works. First I though the reason are the scripts integrated in some of the questions, but in fact I confused the general settings and the survey settings.


This brings another issue. Certain questions in the survey attached are "customised" - they have one or two following questions integrated as columns and therefore their question numbers appear in columns, whereas they shouldn't. Furthermore, all the question numbering down the line messes up because of this.



The simplest solution would be to mark those integrated questions with a help of javascript as "non relevant for question numbering" I suppose. I have no idea how the script would look like.

Another option would be to correct already used script so a question would be copied/transferred in the column of a previous question by leaving out the "th" definition, that is to say the question name. But I think the question itself would be still counted as any other regular question so it's not really a solution.

A sample survey is attached, the scripts used for tailoring are included.


And something else appeared: in certain questions a new line is created right behind the question number.





File Attachment:

File Name: limesurvey...4165.lss
File Size:122 KB


I hope all this makes sense.
Attachments:
Last Edit: 3 years 2 weeks ago by envitera. Reason: few grammar corrections

Please Log in to join the conversation.

More
3 years 2 weeks ago #114148 by envitera
envitera replied the topic: I can't show question numbers or codes ?
Concerning the new line after a question number the problem were whitespace characters which appeared out of nowhere inside the paragraph tags. So instead:
<p>
	My question</p>
should be:
My question

Maybe this has something to do with the option "Hide tip" in the question advanced settings. However, if that happens deleting everything around the question text (including the <p> tags) will help.

Please Log in to join the conversation.

More
3 years 2 weeks ago #114156 by tpartner
tpartner replied the topic: I can't show question numbers or codes ?
Can you activate a test survey?

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
3 years 2 weeks ago #114158 by envitera
envitera replied the topic: I can't show question numbers or codes ?
The link to the test survey. It's similar to the .lss I posted in my last post.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!