Check out the LimeSurvey source code on GitHub!

The questions on "email settings"

More
5 years 8 months ago #60624 by iwitw
I have an email account of Gmail, and I wanna send email invitation to participants from limesurvey with Gmail smtp, I did email setting like the following:



The results was to:



Would you please help me to figure out where is the configure mistake?

Thanks a lot.
Attachments:

Please Log in to join the conversation.

More
5 years 8 months ago #60625 by jcleeland
A quick look at google suggests that you should enable SSL - maybe turn "SMTP SSL/TLS" to "On"?

Please Log in to join the conversation.

More
5 years 8 months ago #60662 by iwitw
Thank you Jcleeland.

I turn "SMTP SSL/TLS" to "SSL" like this:



It still didn't work as:



I have no idea about if I need some required configuration on Gmail account.
Do you think so?

And now what I want is could find a available SMTP email could help me send these invitations to participants, so please give me your suggestions if you know any email Website which could works well in limesurvey.

Thanks.
Attachments:

Please Log in to join the conversation.

More
5 years 8 months ago #60668 by jcleeland
I have to admit, I would have been surprised if google would allow their server to be used by an online application to send out mass emails.

Have you tried using the default PHP(Default) setting instead of SMTP? A properly set up web server should work fine using this.

Otherwise it's up to you to find someone who is happy for their SMTP email server to be used for this purpose.

Please Log in to join the conversation.

More
5 years 8 months ago #60681 by iwitw
Really thanks for your reply, jcleelandB)

Actually, I tried using PHP(default), like:



and the result was to:



Why? Did I need to configure some PHP files, if yes, would you please guide me how to do it?

Thanks a lot.
Attachments:

Please Log in to join the conversation.

More
5 years 8 months ago #60923 by pwmowers
When I looked at the SMTP address, I noticed that you are missing the port number. The address needs to be in the format of:

smtp.gmail.com:465

where the address is for your SMTP server, and the 465 is the port number your mail server is listening to when using SSL. Without a port number, you are in effect trying to call the server with dialing the phone. The port number varies with the server.

see GMail Configuration

Hope this helps.

Pat

Please Log in to join the conversation.

More
5 years 8 months ago #60928 by iwitw
Thanks for your answer, Pat.

I tested in the way you suggested. Mais it still doesn't work.
Please see the following pix:





Any probelms are there?

Thanks again.

Colin
Attachments:

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form