several languages in advanced options

More
5 years 10 months ago #60481 by Tom_Ryans
Hi,

I'm setting up a survey with 2 languages (french and german). I have a lot of questions of the following type: multiple numerical input (including a slider).

The only problem is, that I can't find how to use 2 different languages in the advanced settings (especially for "minimum/maximum value").

Any help is welcome? :)

Thx,
Tom

Please Log in to join the conversation.

More
5 years 10 months ago #60491 by DenisChenu
Hello,

It's not directly implemented in LS core, but you can use some css to do that (in fr/en, adapt for de/en ;) ). But you can't have different value for each langage : you hav to use 2 different question.

For prefix/suffix:
put in Answer prefix
<span class="fr">moins</span><span class="en">less</span>
And same for more/plus

And in template.css:
html:lang(en) .fr{display:none}
html:lang(fr) .en{display:none}

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 10 months ago #60511 by Tom_Ryans
Excellent!!

Thx for the quick help.

Best,
Tom

Please Log in to join the conversation.

More
4 years 5 months ago #86942 by dirkbece
Where do i place the code in the CSS?
which part?

Please Log in to join the conversation.

More
4 years 5 months ago - 4 years 5 months ago #86947 by dirkbece

File Attachment:

File Name: template.doc
File Size:69 KB

dirkbece wrote: Where do i place the code in the CSS?
which part?


I have put the code in my css.
and change the field with the given code.

No i see them both.

Who can help me?
I think my css and het given code are not working together

I have add my css as a appendix

Regards,

Me
Attachments:
Last Edit: 4 years 5 months ago by dirkbece.

Please Log in to join the conversation.

More
4 years 5 months ago #86948 by DenisChenu
At end of template.css file for example

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 5 months ago #86950 by dirkbece
see my attachment.

Im working with version 1.92+

Please Log in to join the conversation.

More
4 years 5 months ago #86951 by DenisChenu
Send a active test link please.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 5 months ago #86952 by dirkbece

Please Log in to join the conversation.

More
4 years 5 months ago #86956 by DenisChenu
No,

An active survey link with a question and an example
Like this one : demonstration.sondages.pro/14415/lang-fr

And i'm not sur it work for IE6

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 5 months ago #86958 by dirkbece
i work with ie8, firefox or chrome. With all it doesn't work.

See question four for example

securitycode is: whc6s
link is: www.bcinfo.nl/index.php?sid=79446&newtest=Y&lang=fr

Please Log in to join the conversation.

More
4 years 5 months ago #86986 by dirkbece
everything is working now.

I think that my stylesheet didn't refresh

Please Log in to join the conversation.

More
4 years 5 months ago #87023 by McdanielMackenzie
I've resembled that problem. Stylesheets are cached; so it's important to clear your cache if you're doing anything in templates or CSS.

Please Log in to join the conversation.