Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Setting conditions (for branching/hide/show) is not working

Setting conditions (for branching/hide/show) is not working 5 years 7 months ago #60219

I tried the "setting conditions" function for a question and it is not working. The question appears whether or not the condition on the previous question was checked or not. I have the latest version of limesurvey (Version 1.90+ Build 9642). I even imported a survey I created using an older limesurvey version in which I had created a branching logic (which worked in the older limesurvey version) into the newer limesurvey version and it stopped working. Is there some new step in the newer limesurvey version that I am missing?

Any help would be appreciated!

Bob
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 7 months ago #60274

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6568
  • Thank you received: 1477
  • Karma: 579
Bob, could you give some more specific details on the question types and maybe a screenshot of the conditions so we can test.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 1 month ago #68402

  • Chanello
  • Chanello's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Hi!

I don't know whether or not this topic has been closed, but I am curently experiencing the same problem. I have set a condition for a question that only needs to be shown if a certain answer is provided. Unfortunately, the question is always shown..Hopefully you can help me..

Thanks in advance,

Grt,

Chanel
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 1 month ago #68409

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6568
  • Thank you received: 1477
  • Karma: 579
Hi Chanel, can you attach a sample survey for us to test?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 1 month ago #68413

  • Chanello
  • Chanello's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
I have attached the survey structure..

File Attachment:

File Name: limesurvey...6718.lss
File Size:206 KB
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 1 month ago #68415

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6568
  • Thank you received: 1477
  • Karma: 579
Can you give us a hint as to which conditions are not working?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 1 month ago #68416

  • Chanello
  • Chanello's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Question group: De software ProActive
Questions:
7.1.1
7.2.1
8.1.1
8.1.2
8.2.1
8.2.2
8.3.1

Question group: Het implementatieproces
Questions:
10.9.1

Question group: Totale tevredenheid
Questions:
28.1
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 1 month ago #68422

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6568
  • Thank you received: 1477
  • Karma: 579
These conditions all seem to be working for me.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 1 month ago #68423

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6029
  • Thank you received: 373
  • Karma: 260
It seems to be working fine here. If I choose "Zeer ontevreden" the according conditionally conected question pops up.

Maybe you should explain the problem in more detail.

Do you use an old, outdated template?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 1 month ago #68426

  • Chanello
  • Chanello's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
That's weird :huh:

Just to be sure that we are talking about the same thing:

The conditions that I have installed is that these questions only need to be shown if a certain answer is given in the question before.. In my case, these questions are, despite the given conditions, shown at all times in the survey..

If this seems to be working correctly with you, what could be the problem in my case? I have also tested, and the problem exists in Firefox, Internet Explorer and Chrome, so I don't think it is a "browser problem"...
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 1 month ago #68427

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6568
  • Thank you received: 1477
  • Karma: 579
They do seem to be working correctly for us.

As Mazi suggests, it may be a template problem. Can you test with the shipped default template?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 5 years 3 weeks ago #68602

  • Chanello
  • Chanello's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Problem solved! I've changed the template and it seems to be working correctly now! THANK YOU SO MUCH for all the help, I would've never figured this out by myself!

Thank you!

Grt,

Chanel
The administrator has disabled public write access.

Setting conditions (for branching/hide/show) is not working 2 years 3 months ago #112165

  • georgebradford
  • georgebradford's Avatar
  • Offline
  • Senior Lime
  • Posts: 40
  • Thank you received: 1
  • Karma: 1
Hi Everyone,

I just ran into this same issue with a fairly current version of LS (Version 2.05+ Build 140422): conditional branching will not work in a non-standard template.

Any ideas why this function remains problematic or is this issue on a trouble-shooting list?

Just wondering. I'm working around the problem by using a standard template and wanted someone to know the problem seems to still exist.


-George
The administrator has disabled public write access.
Time to create page: 1.147 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form