same user across multiple surveys?

More
1 year 22 hours ago #136774 by Mariebottine
Mariebottine replied the topic: same user across multiple surveys?
I answered myself to my question : Excel used semi-colon instead of comma, so I just switched this when I imported the csv file and it worked.
I'll get all this finally!

Please Log in to join the conversation.

More
1 year 21 hours ago #136775 by holch
holch replied the topic: same user across multiple surveys?
Yes, Excel is not the best tool to use with CSV. Who knows why, MS is not following the standard for CSV and is using semi-colon instead of comma.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
11 months 3 weeks ago #137186 by Mariebottine
Mariebottine replied the topic: same user across multiple surveys?
Me again! I'm almost done!

I'm trying to generate individual links which include the token that I will send manually, following the tip presented in this section : manual.limesurvey.org/Survey_participants#Dummy_Tokens

I've tried all of theses URLs, but each time it requires for the participant to enter the token (for the exemple the token is : VM_0_K). I'd like that it goes directly to the welcome page.
http://url-to-my-limesurvey-installation/index.php/273467?lang=fr/token/VM_0_K
http://url-to-my-limesurvey-installation/index.php/273467?lang=fr/token/{VM_0_K}
http://url-to-my-limesurvey-installation/index.php/273467?lang=fr/token=VM_0_K
http://url-to-my-limesurvey-installation/index.php/273467?lang=fr/token/{VM_0_K}
http://url-to-my-limesurvey-installation/index.php/273467?lang=fr/{VM_0_K}
http://url-to-my-limesurvey-installation/index.php/273467?lang=fr/VM_0_K
Can somebody help me? Maybe there is something in my general settings that I didn't set properly...
I'm using Version 2.50+ Build 160426

Thanks a lot!

Please Log in to join the conversation.

More
11 months 3 weeks ago #137188 by holch
holch replied the topic: same user across multiple surveys?
So you did upload your tokens via csv and the tokens are visible in the token table, correct?

When you go over the little wheel symbol at the beginning of the token table you should see the actual URL. Copy this url and use it as your base for generating your token links via Excel. You need to check how this example URL uses the tokens and the language.

I guess the problem is the ?lang=fr. After that probably LS doesn't expect any other attribute or can't read the format with "/".

Probably the link would look like this: http://url-to-my-limesurvey-installation/index.php/273467/lang/fr/token/VM_0_K or http://url-to-my-limesurvey-installation/index.php/273467token/VM_0_K/lang/fr/ or http://url-to-my-limesurvey-installation/index.php/273467token/VM_0_K?lang=fr

I will check how it looks like in my installation, but first I have to fire it up and see if I have a survey with tokens somewhere to check.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
11 months 3 weeks ago #137189 by jelo
jelo replied the topic: same user across multiple surveys?

holch wrote: Who knows why, MS is not following the standard for CSV and is using semi-colon instead of comma.

Excel is using comma or semi-colon depending on your regional language number settings in Windows.
There is a field "List Separator" which is comma in American English but not in many other languages. There the list separator is often a semi-colon.

Add "sep=;" as the first line of your CSV to tell Excel to use
It is better to use LibreOffice or CSVEdit as tools.

If you still want to use Excel, you can rename the suffix .csv into .txt. Then the import dialog will allow you to select the delimiter.
Or add “sep=,” to the first line of your CSV file – without the quotes to tell Excel what should be used as a separator for the following lines.
The following user(s) said Thank You: Mariebottine

Please Log in to join the conversation.

More
11 months 3 weeks ago #137190 by holch
holch replied the topic: same user across multiple surveys?
So I created a study with tokens and here we go, this is how your links should look like:
http://url-to-your-limesurvey-installation/index.php/survey/index/sid/282267/token/EiV8ay~g4xYwGT0/lang/en/newtest/Y

The new test is not really necessary.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: Mariebottine

Please Log in to join the conversation.

More
11 months 2 weeks ago #137339 by Mariebottine
Mariebottine replied the topic: same user across multiple surveys?
It works, yahoo!!!!

I finally used this url : http://url-to-your-limesurvey-installation/index.php/survey/index/sid/282267/lang/fr/token/EiV8ay~g4xYwGT0
Seems like the final order (lang vs token) is not that important, and it helped me generate a lot of different links with tokens.

And I had another bug : when I imported the CSV Token table created with the first survey (dummy emails), everything would upload except the tokens. I finally switched from Excel to LibreOffice Calc and everything went well.

I have one final worry : when I activated the surveys, I had a message saying that it was public access, with a button to make it private with invitations, and then it would take me to the token section. I was afraid I skipped a step and didn't activate token, but I haven't seen anything in the token section to activate it and the token table was ok. My guess is that it's all ok, and that people generally don't play in the token section before activating the survey. Am I right?

Thanks a lot for all of your help holch and jelo, without it I'm not sure I would have done this!

Please Log in to join the conversation.

More
11 months 2 weeks ago #137343 by DenisChenu
DenisChenu replied the topic: same user across multiple surveys?

Mariebottine wrote: [...]
I have one final worry : when I activated the surveys, I had a message saying that it was public access, with a button to make it private with invitations, and then it would take me to the token section. I was afraid I skipped a step and didn't activate token, but I haven't seen anything in the token section to activate it and the token table was ok. My guess is that it's all ok, and that people generally don't play in the token section before activating the survey. Am I right?

[...]

Seems you're right :).

If you use the last build : this little bug can be reported.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: Mariebottine

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now